Problem to register upgraded AP 1242 to WLC 4402

Unanswered Question
Aug 14th, 2007
User Badges:

Hi,


I am running a small Cisco WLAN with about 20 APs (all 1242) that are managed by two WLC 4402 (running v4.0.155.0).

WLCs are in Mobility group, serveral WLANs/VLANs are configured (including 802.1x, guest access with WebAuthentication etc.). All APs are configured for the same WLC as primary and the other as secondary. Everthing was working fine until I tried to upgrade another AP from IOS to LWAPP using the Cisco Upgrade tool.


After the AP was flashed and rebooted it started to discover a WLC but fails. The console messages look like this:


*Mar 1 00:00:05.962: %CDP_PD-4-POWER_OK: Full power - AC_ADAPTOR inline power source

*Mar 1 00:00:06.952: %LINK-3-UPDOWN: Interface FastEthernet0, changed state to up

*Mar 1 00:00:07.952: %LINEPROTO-5-UPDOWN:


ap> Line protocol on Interface FastEthernet0, changed state to up


*Mar 1 00:00:25.960: %LWAPP-5-CHANGED: LWAPP changed state to DISCOVERY

Translating "CISCO-LWAPP-CONTROLLER.xxx.yyy"...domain server (10.x.y.z)

*Mar 1 00:00:35.348: %DHCP-6-ADDRESS_ASSIGN: Interface FastEthernet0 assigned DHCP address 10.x.y.z, mask 255.255.254.0, hostname AP0019.3076.fe30

*Mar 1 00:00:36.349: LWAPP_CLIENT_ERROR: lwapp_name_lookup - Could Not resolve CISCO-LWAPP-CONTROLLER.xxx.yyy

*Mar 1 00:00:46.398: %LWAPP-5-CHANGED: LWAPP changed state to JOIN

*Mar 1 00:00:54.397: LWAPP_CLIENT_ERROR_DEBUG: spamHandleJoinTimer: Did not recieve the Join response

*Mar 1 00:00:54.397: LWAPP_CLIENT_ERROR_DEBUG: No more AP manager IP addresses remain.

*Mar 1 00:00:54.397: %SYS-5-RELOAD: Reload requested by LWAPP CLIENT. Reload Reason: DID NOT GET JOIN RESPONSE.

*Mar 1 00:00:54.398: %LWAPP-5-CHANGED: LWAPP changed state to DOWN


The switchport of the AP is configured for the same VLAN as the management and ap-management interface of the controller (not native VLAN), the primary controller is set to master controller mode and I see no other error messages (e. g. on the WLC).


Does anyone know how to fix this problem?

(even adding a "CISCO-LWAPP-CONTROLLER" host in the DNS does not help!!!)

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ankbhasi Tue, 08/14/2007 - 06:33
User Badges:
  • Cisco Employee,

Hi Friend,


Because your AP vlan and your managenet interface vlan are same so you do not need any DNS or DHCP option 43 to be configured.


Your Ap is passing Discovery state and failing join response from controller.


Can you paste the output of "dir flash:" from AP?


Regards,


Ankur

h.bechtel Wed, 08/15/2007 - 00:35
User Badges:

Hi Ankur,


here the output of "dir flash:"


dir flash:

Directory of flash:/


2 -rwx 1048 Aug 14 2007 14:29:38 +00:00 private-multiple-fs

3 -rwx 314 Mar 1 2002 00:00:57 +00:00 env_vars

156 drwx 128 Aug 14 2007 14:29:32 +00:00 c1240-rcvk9w8-mx

10 drwx 256 Aug 15 2007 07:15:47 +00:00 c1240-k9w8-mx.123-11.JX


15998976 bytes total (11196416 bytes free)

AP0019.3076.fe30#


Is there something wrong?



Kind regards,

Hagen

h.bechtel Wed, 08/15/2007 - 01:38
User Badges:

Hello again,


I configured the secondary WLC?s management and ap-management interfaces for the native VLAN (1) and assigned the switchport of the AP to be access port in VLAN1.


After this the AP registered at the secondary WLC. Then I configured the AP (IP, primary and secondary controller) and it switched to the primary controller immediately.


Can anyone explain this behaviour? I thought that there is no need to use the native VLAN for WLC and AP.

h.bechtel Wed, 08/15/2007 - 04:11
User Badges:

Hi!


I have solved the issue.


I had to configure the management and ap-management interfaces as untagged on the WLCs and configure the switchports of the WLCs "switchport trunk native vlan xxx" (xxx means the WLAN-VLAN where the APs and WLCs reside.) I am a little bit confused as I never saw any hint on ths fact in the documentations, design guides etc...


Actions

This Discussion

 

 

Trending Topics - Security & Network