Trouble routing vlans 3560

Unanswered Question
Aug 14th, 2007

I have a 3560, typical setup with voice and data

interface GigabitEthernet0/6

switchport access vlan 200

switchport mode access

switchport voice vlan 100

spanning-tree portfast

Vlan 200 has an interface

Vlan 100 has an interface

But i cant get the two to route? What is the trick?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
ankbhasi Tue, 08/14/2007 - 07:00

Hi Friend,

Can you check if "ip routing" is enabled? Can you post the output of "sh ip route"?



glen.grant Tue, 08/14/2007 - 07:02

Make sure you have created the layer 2 vlans , check with a "show vlan" command and those 2 should show in the list as active . Make sure your mask is correct on both layer 3 definitions and the clients have their default gateway pointing to the router address for the given vlan.

Tommer Catlin Tue, 08/14/2007 - 07:06

The vlans are created.

interface Vlan100

ip address

no ip route-cache


interface Vlan200

ip address

no ip route-cache

Should my gateways be the interface of the VLANs?

Edison Ortiz Tue, 08/14/2007 - 07:08

> Should my gateways be the interface of the VLANs?


Can you ping workstations on each Vlan from the switch ?

Can we see a 'show ip route' from the switch ?

Tommer Catlin Tue, 08/14/2007 - 07:11

Sorry, not onsite.

So for PC 1 I have set gateway

On PC 2

I have set gateway

I cant ping either side, but at the switch, I can ping the interfaces of the VLANs. (havent tried the pcs)

Im offsite, but heading back shortly. It's really odd, because I thought the VLANS would automagically route between them if they were created on the switch.

royalblues Tue, 08/14/2007 - 07:34

If these are windows machines, please ensure that you have turned off the local firewall settings on them.


Tommer Catlin Tue, 08/14/2007 - 07:38

Yep, cant ping them still. Im trying to verify that routing between the VLANs will work on this 3560, or do I need to have a separate router?? because I thought that the 3560's work as layer 3 switches and can route accordingly.

Edison Ortiz Tue, 08/14/2007 - 07:49

You don't need a separate router, please post the 'show ip route' from the switch.

Tommer Catlin Tue, 08/14/2007 - 07:52

Thanks Edison, I will do this when I get a chance.

If I took this out of the box and wanted to configure VLAN 100 and VLAN 200 (voice and Data) What steps would take?

Thanks everyone!

glen.grant Tue, 08/14/2007 - 08:22

this is the layer 3 info did you create the layer 2 vlans ??? You need both the layer 2 side and the layer 3 side in order to work . Use the show vlan command and see if the layer 2 vlans are created. Just because you put the switchport access vlan 100 command on the interface does not mean the layer 2 vlan is created .


conf t

vlan 100

vlan 200


write mem


The vlans are created.

interface Vlan100

ip address

no ip route-cache


interface Vlan200

ip address

no ip route-cache

Tommer Catlin Tue, 08/14/2007 - 08:54

I think my problem is I cant ping a PC in the Access mode and a PC in the Voice mode on the other port. They both have to be set to Access. If I have had Cisco Phone plugged in, then CDP would take over and I could then ping the phone.

Edison Ortiz Tue, 08/14/2007 - 14:10

If you connect a PC on a port where you only configure the Voice Vlan, the Access Vlan will default to Vlan1.

If you aren't using Vlan1 for PC Access, you must manually configure all switchport for the desired Access Vlan in addition to the Voice Vlan.


This Discussion