3825 Voice Gateway with ISDN E1 line

Unanswered Question
Aug 15th, 2007

Hi all,

I have 1 Cisco 3825 Router with module NM-1CE1T1-PRI

And i have one line E1 connect to this

I have configed Cisco AS5300 work with E1 line and callmanager, but with 3825 i have some problem

Any one can send me config example with 3825 router to accept incoming call and forward to callmanager

Thanks alot, vote 5* for your help

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
conkinkinconkinkin Wed, 08/15/2007 - 21:00

Any one have configed Cisco Router 3825 to work with ISDN E1 line and callmanager?

Can you share your config sample?

Thanks alot

conkinkinconkinkin Sun, 08/19/2007 - 10:19

I use H323 protocol

On my router 3825 i use "NM-1CE1T1-PRI" module

This module support E1 and T1 line

I use command "card type E1", and i can see interface from 0-30, E1 port on module is port 1/1.

But after config channel 15, i didn't find command to config voice port 1/1:D

(with E1 module, voice port is config to receive incoming call, and place out going call)

May be have some different with module NM-1CE1T1-PRI

Any one can help, thanks

royalblues Sun, 08/19/2007 - 11:16

here's a sample config from a router running H323

isdn switch-type primary-net5

controller E1 0/2/0

framing NO-CRC4

pri-group timeslots 1-31

interface Serial0/2/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn send-alerting

isdn sending-complete

no cdp enable

voice-port 0/2/0:15

dial-peer voice 1 voip

destination-pattern

session target ipv4:

dtmf-relay h245-alphanumeric

codec g711ulaw

HTH

Narayan

conkinkinconkinkin Mon, 08/20/2007 - 00:29

Thanks Narayan, i vote 5* for your help

I have configed ISDN E1 with AS5300

But with this module i did not see voice-port :15 to config

Do you see this problem before? May be line E1 down or i did not config right ?

I user NM-1CE1T1-PRI module, after change card type to E1, i see all channel 0-30 but can not see voice port :15

conkinkinconkinkin Thu, 09/06/2007 - 03:05

Hi, all

Any one configed module NM-1CE1T1-PRI for voice.

After i config controller on e1 interface, config linecode, framing, pri timeslot, I didn't see any "voice port"

I sure that linecode, framing, e1 line is ok, because i use this e1 line with AS5350 and all thing run well

May be have some problem with module NM-1CE1T1-PRI. Do this module support Voice??

Or have some problem in hardware?

Thanks for all help

conkinkinconkinkin Fri, 09/07/2007 - 20:42

I use line E1, after config

"controller E1 1/0

framing NO-CRC4

pri-group timeslots 1-31 "

I see interface serial 1/0:0-1/0:30

And I config interface serial1/0:15( d channel)

"interface Serial1/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice modem 64

no cdp enable

!"

But after that, i did not see any voice port while type "show run"

I use software Version 12.4(13b)

pklos Tue, 09/11/2007 - 03:12

Do you have network-clock-select command?

And I think you should have "incoming-voice voice" instead modem 64.

--

regards,

pk

thomasarun Tue, 09/11/2007 - 21:21

You can try one more command in controller E1

'clock source still if it is not showing u can change the IOS to 12.4T

conkinkinconkinkin Thu, 09/13/2007 - 00:55

Thanks thomasarun

I upgraded new software, new version is:

"Cisco IOS Software, 3800 Software (C3825-IPVOICEK9-M), Version 12.4(4)T8, RELEASE SOFTWARE (fc3)"

"Cisco 3825 (revision 1.0) with 226304K/35840K bytes of memory.

Processor board ID FHK0949F0LM

2 Gigabit Ethernet interfaces

31 Serial interfaces

1 Channelized E1/PRI port

4 Voice FXO interfaces

8 Voice FXS interfaces

DRAM configuration is 64 bits wide with parity enabled.

479K bytes of NVRAM.

62720K bytes of ATA System CompactFlash (Read/Write)"

But after try each of: clock source external, line, external, voice port 1/0:D did not show (my E1 port is 1/0)

May be this module NM-1CE1T1-PRI have some different in configuration.

Any one can help?

Thanks

thomasarun Thu, 09/13/2007 - 02:40

card type e1

Controller E1

framing

linecode

clock source

pri-group timeslots 1-31

then can u give the sh run details.

conkinkinconkinkin Sun, 09/16/2007 - 18:56

Thanks thomasarun

-------------

here is my 3825 configuration:

GW#sh run

Building configuration...

card type e1 1

!

ip subnet-zero

ip cef

!

no ip domain lookup

isdn switch-type primary-net5

voice-card 0

no dspfarm

!

voice service voip

allow-connections h323 to h323

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback cisco

h323

no h225 timeout keepalive

no call service stop

call start slow

!

!

!

voice class codec 1

codec preference 1 g729r8

codec preference 2 g729br8

codec preference 3 g711ulaw

!

!

!

voice class h323 1

h225 timeout tcp establish 3

telephony-service ccm-compatible

ccm-compatible

!

fax interface-type fax-mail

!

controller E1 1/0

framing NO-CRC4

clock source internal

pri-group timeslots 1-31

!

interface GigabitEthernet0/0

ip address 192.168.10.100 255.255.255.0

duplex auto

speed auto

media-type rj45

negotiation auto

h323-gateway voip interface

h323-gateway voip h323-id h323Gateway

h323-gateway voip bind srcaddr 192.168.10.100

!

interface Serial1/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-4ess

isdn incoming-voice modem

isdn send-alerting

isdn sending-complete

no cdp enable

!

interface Dialer0

no ip address

!

interface Group-Async0

physical-layer async

no ip address

encapsulation ppp

dialer in-band

dialer idle-timeout 900

no group-range

!

ip default-gateway 192.168.10.1

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.10.1

!

control-plane

!

dial-peer voice 19 voip

answer-address 19..

!

dial-peer voice 9 pots

destination-pattern 9T

!

dial-peer voice 2 voip

preference 1

destination-pattern 1...

voice-class codec 1

voice-class h323 1

session target ipv4:192.168.10.200

dtmf-relay h245-alphanumeric

no call fallback

no vad

!

dial-peer voice 1 pots

answer-address .

!

gateway

timer receive-rtp 1200

!

!

line con 0

stopbits 1

line aux 0

modem InOut

transport input all

stopbits 1

!

scheduler allocate 20000 1000

!

end

GW#

-----------------

And here is output about all module

NAME: "PVDMII DSP SIMM with four DSPs on Slot 0 SubSlot 4", DESCR: "PVDMII DSP SIMM with four DSPs"

PID: PVDM2-64 , VID: NA , SN: FOC094432Q8

NAME: "One Port Channelized E1/T1/PRI with Integrated CSU on Slot 1", DESCR: "One Port Channelized E1/T1/PRI with Integrated CSU"

PID: NM-1CE1T1-PRI= , VID: 1.0, SN: FOC09360EZ8

----------

conkinkinconkinkin Mon, 09/17/2007 - 02:11

My E1 interface is on slot 1, port 0

After config controller e1 1/0, i config network-clock-select but see:

GW(config)#network-clock-select 1 e1 1/0

% Incomplete command.

GW(config)#network-clock-participate slot 1

Slot is empty or does not support clock participate

And when config voice card i see the

GW(config)#voice-card 1

^

% Invalid input detected at '^' marker.

GW(config)#voice-card 0

GW(config-voicecard)#

My E1 interface on slot 1, i cannot config voice card 1

conkinkinconkinkin Wed, 09/26/2007 - 19:36

Thanks all,

My problem is module NM-1CE1T1-PRI don't support voice.

If you wan to support voice you need module like:

NM-HDV2-1T1/E1(IP Communications High-Density Digital Voice NM with 1 T1/E1)

NM-HDV2-1T1/E1=(IP Communications High-Density Digital Voice NM with 1 T1/E1)

NM-HDV2-2T1/E1(IP Communications High-Density Digital Voice NM with 2 T1/E1)

NM-HDV2-2T1/E1=(IP Communications High-Density Digital Voice NM with 2 T1/E1)

....

or

VWIC2-1MFT-T1/E1

...

Actions

This Discussion