problem installing CSD secure desktop in ASA 8.0(2)

Answered Question

I am trying to setup securedesktop 3.2.0.136 on ASA5510 running 8.0(2) with ASDM 6.0(2). I get this error when I try to install it.


ERROR: Unable to use CSD image. Try another.


I did sh webvpn csd image to validate the file and it seems ok. I've tried to redownload it from the cisco site, but getting the same error. Is the file messed up?

Correct Answer by s.gariepy about 9 years 6 months ago

just do a "no" command

Correct Answer by mlundbom1 about 9 years 6 months ago

I'm currently running on 32. But, I'm on 8.0 so that might give a difference.



/M

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
Benjamin Story Fri, 08/17/2007 - 17:54

I'm also experiencing this problem but with 7.2(2) as I didn't catch that 3.2 was for >=8.0. Now when I try to install CSD 3.1.x I get the same error as above.

s.gariepy Tue, 08/21/2007 - 05:56

Same thing here :


Activating CSD in ASDM give :

-Start-

[OK] webvpn

webvpn

[ERROR] csd enable

Unable to use CSD image. Try another

-End-


ASA : 7.2(2)

ASDM : 5.2(2)

CSD IMAGE :

securedesktop-asa-3.1.1.45-k9.pkg

or

securedesktop-asa-3.2.0.136-k9.pkg


Here is what i've done ( After the failure in ASDM)


asa-*****# show webvpn csd image disk0:/securedesktop-asa-3.1.1.29-k9.pkg

This is a valid Cisco Secure Desktop image:

Version : 3.1.1.29

Built on : Tue 04/18/2006 10:19:43.03

asa-*****# conf t

asa-*****(config)# webvpn

asa-*****(config-webvpn)# csd image disk0:/securedesktop-asa-3.1.1.29-k9.pkg

asa-*****(config-webvpn)# csd enable

ERROR: Unable to use CSD image. Try another


Privilege Level : 15


Enough free space on flash.


Any idea?

mlundbom1 Tue, 08/21/2007 - 14:49

Just experienced the same problem.

It was not a licensing issue to me.. What I did (as a desperate attempt, not finding any other solution) was to raise the Maximum Cache-size on the page for CSD-setup. Tried again, and - voil?...


Good luck. :)



/M

s.gariepy Wed, 08/22/2007 - 04:44

This option is not available in ASDM for ASA version 7.0(2). I find something in CLI :


# conf t

# webvpn

# cache

# max-object-size


How much ? What was the value ?

s.gariepy Wed, 08/22/2007 - 08:28

We found that it seem to be a cache problem.

But in version 7.x there is no command to enlarge the cache.


We tried to clean up the cache but it does not work at all on the 7.x ( the same cleanup work well on the 8.x)


Is there a way to do that? We are close ...

Nelson Rodrigues Thu, 08/23/2007 - 05:50

In ASA 7.1.x and 7.2.x you don't have the "webvpn cache-fs" command. You don't need it.

There's plenty of cache internally allocated for the CSD and SVC images .


With 8.0.x, because you can have up to 4 AnyConnect SSL VPN images and 1 CSD image, we give you the ability to allocate cache with the command, based on your need.


Regards,


Nelson


Benjamin Story Thu, 08/23/2007 - 05:53

While that's true we SHOULD not need it. We apparently do or we need a way to clear the cache.

Correct Answer
mlundbom1 Wed, 08/22/2007 - 13:07

I'm currently running on 32. But, I'm on 8.0 so that might give a difference.



/M

s.gariepy Thu, 08/23/2007 - 05:14

Cache issue.


We managed to enable the csd!


flush all trace of sdesktop.

try to flush the trace within the cache too.

reload

enable csd


But i still have a problem. The section of csd is incomplete ...

Actions

This Discussion