Upgrading to 4.1.185: tftp server on WCS has a 32MB limit: TRANSFER FAILED

Unanswered Question

When attempting to download 4.1.185.0 WLC code to the controller from the WCS, it fails with the following message:


TRANSFER FAILED


Apparently, this is due to the fact that the size of the image is now greater than 32MB. Although the updates to the WLC now support images this size, the tftp server built into the WCS appears to have a problem with files greater than 32MB (nice!).


So... if you want to upgrade your controllers to 4.1.185.0 (or later) you will need to run a tftp server on a machine other than the WCS.


Working with Cisco TAC, the recommended the following shareware/freeware/evalware version that seems to work successfully can be found here:


http://www.tallsoft.com/tftpserver.htm


I hope this saves some time if you are running into this problem with the 4.1.185 upgrade.


I have requested that (yet another) WCS bug be opened up which addresses this problem.


HTH


- John

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ericgarnel Thu, 08/16/2007 - 08:24

You could also use a linux box, or a live linux CD with the image on a USB drive.


I pushed 4.1.185.0 to 4 controllers this am with no issues using a linux box with the standard tftp server.

At some point in the future, perhaps the code will support ftp, rcp, scp, etc...

sbeauton Thu, 08/16/2007 - 12:02

I was having this same problem but I was running 4.0.179.11. According to TAC you have to upgrade to verision 4-0-217 or later before you can upgrade to 4-1-181. Hope this helps

Unfortunately, I was already running 4.1.171 on the WLC and 4.1.91 on the WCS.


The problem that was "fixed" by the upgrade was in the WLC not being able to accept code files larger than 32MB.


However, Cisco never bothered to update the tftp server on the WCS to be able to SEND tftp files larger than 32MB. Prior to WLC v4.1.185, the WCS was able to handle the tftp transfer with no problems.


There needs to be some better testing on these products before they ship.


- John

gary.hostetler Fri, 08/17/2007 - 19:17

I just used WinAgents TFTP Server by tandem software tonight to upload the 185 image. Worked fine. Well that is until I realized my access points hadn't finsished upgrading from the in between upgrades and now they're corrupted. I have spares so I'll just plug them in Monday until I figure out how to reinstall the software.


zhenningx Wed, 08/22/2007 - 06:49

I just did 4.1.185 upgrade. I used a linux box as tftp server. That works great!

Actions

This Discussion

 

 

Trending Topics - Security & Network