T1 CAS and T1 PRI fax Problem

Unanswered Question
Aug 16th, 2007

We have 2 T1's coming into a voice gw. One is connected to telco via a pri for outbound calls. The other is connected to a IVR system via a T1 Cas e&m. The IVR is setup of to send faxes out and a dialpeer is setup to send these faxes to the PRI. Non Fax calls work fine for transfer..but Fax calls fail. I have noticed that on a transfer call the codec is negotiated @ g711 but the faxes have a codec of None. Is there something I am missing...these calls are non voip and a dsp is not used for the call...please advise.

Joe

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
joeharb Thu, 08/16/2007 - 07:31

temp2811VGW#show controllers T1

T1 0/1/0 is up.

Applique type is Channelized T1

Cablelength is long gain36 0db

Description: Connection to IVR

No alarms detected.

alarm-trigger is not set

Soaking time: 3, Clearance time: 10

AIS State:Clear LOS State:Clear LOF State:Clear

Version info Firmware: 20060711, FPGA: 13, spm_count = 0

Framing is SF, Line Code is AMI, Clock Source is Line.

CRC Threshold is 320. Reported from firmware is 320.

Data in current interval (248 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Total Data (last 24 hours)

0 Line Code Violations, 0 Path Code Violations,

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

T1 0/1/1 is up.

Applique type is Channelized T1

Cablelength is long gain36 0db

Description: Connection to PRI

No alarms detected.

alarm-trigger is not set

Soaking time: 3, Clearance time: 10

AIS State:Clear LOS State:Clear LOF State:Clear

Version info Firmware: 20060711, FPGA: 13, spm_count = 0

Framing is ESF, Line Code is B8ZS, Clock Source is Line.

CRC Threshold is 320. Reported from firmware is 320.

Data in current interval (248 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Total Data (last 24 hours)

326 Line Code Violations, 4 Path Code Violations,

4 Slip Secs, 0 Fr Loss Secs, 1 Line Err Secs, 1 Degraded Mins,

4 Errored Secs, 1 Bursty Err Secs, 0 Severely Err Secs, 20753 Unavail Secs

I am pretty sure the last 24 hours includes the time we were getting the pri setup with telco...

dial-peer voice 23 pots

fax rate fax

direct-inward-dial

port 0/1/0:23

!

dial-peer voice 1270441 pots

description Outgoing PRI

preference 1

destination-pattern 1[2-9].........

fax rate fax

port 0/1/1:23

forward-digits 10

Paolo Bevilacqua Thu, 08/16/2007 - 08:15

Hi,

if as you say the errors are related to setup times, it looks fine and well.

The only thing I canking of that you can try, is "no echo-cancel enable" on the IVR port, or both, and some tinkering with "output" and "input" gains. These are all under "voice-port".

joeharb Thu, 08/16/2007 - 08:21

Thought about that...do you think the fact that I see the codec negotiated on a voice call but not on a fax could could be an issue...

Thanks for you help on this...

Joe

Paolo Bevilacqua Thu, 08/16/2007 - 08:55

Well, the call is hairpinned, that is no codec should be involved for either fax or voice.

The correct setting would be then "fax rate disable" under dial-peer.

joeharb Thu, 08/16/2007 - 13:23

Ok,

I understand the hairpinning...I changed my outgoing dialpeer to a fxo port and the fax completes fine...does this lead to something on the pri...I haven't made any changes to the config other than the dial-peer choosen...

Thanks,

Joe

Paolo Bevilacqua Thu, 08/16/2007 - 13:58

Really no config problem is evident here. You may want to give this to the TAC, before you do that you may want upgrade something recent and stable, like 12.4(16).

EDIT:

One more thing. Please configure:

network-clock-participate wic x/y

network-clock-select 1 T1 x/y/z

Then confirm that the IVR system can be set for external clock, and set clock internal on the corresponding router T1. Check that you are still slip-free in show controller as you are now. That would be the preferred clock configuration.

Actions

This Discussion