Default-Gateway -not-set?

Unanswered Question

Question, I have a 3560 switch with 1 G0/0 enabled, 1 serial port with a subinterface. I have configure the both ports and the default gateway yet, when I do a sh ip route I received the following error Default-Gateway not set. I've even tried to use the actual ip address. I still receive the same error any suggestions?

!

interface Serial0/0/0

description ISP Circuit

no ip address

ip access-group 10 in

ip access-group 10 out

no ip proxy-arp

encapsulation frame-relay IETF

clockrate 2000000

interface Serial0/0/0.1 point-to-point

description connected to Internet

ip address x.x.x.x

ip access-group 10 in

ip access-group 10 out

no ip mroute-cache

frame-relay interface-dlci 384

!

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0/0/0.1

or

ip route 0.0.0.0 0.0.0.0 X.X.X.X

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Richard Burts Thu, 08/16/2007 - 08:11

Ernest

Is ip routing enabled? If routing is enabled then the default route is frequently referred to as gateway of last resort. When it talks about default gateway not being defined it sounds like it is still operating as a layer 2 switch which expects to have configuered ip default-gateway x.x.x.x and not ip route 0.0.0.0.

Perhaps you could post the config of the 3560 and also the exact syntax of the error message?

HTH

Rick

Thanks,

I have attached the error and config file

sho ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area, * - didate default, U - per-user static route o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ######

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

!

resource policy

!

ip subnet-zero

no ip source-route

!

!

ip cef

no ip dhcp use vrf connected

!

!

no ip bootp server

ip domain name #########

ip name-server #########

ip name-server #########

ip ssh time-out 60

ip ssh authentication-retries 2

ip ssh version 2

no ip ips deny-action ips-interface

!

!

!

username ########

!

interface GigabitEthernet0/0

description SonicWall-WAN-Port

ip address #############

no ip proxy-arp

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

no ip proxy-arp

shutdown

duplex auto

speed auto

no cdp enable

!

interface Serial0/0/0

description ISP Circuit

no ip address

ip access-group 101 in

ip access-group 101 out

no ip proxy-arp

encapsulation frame-relay IETF

clockrate 2000000

!

interface Serial0/0/0.1 point-to-point

description connected to Internet

ip address #################

ip access-group 101 in

ip access-group 101 out

no ip mroute-cache

frame-relay interface-dlci 384

!

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0/0/0.1

!

!

no ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 600 life 86400 requests 10000

!

logging ##############

access-list 101 deny tcp any any eq 11 log

!

!

control-plane

!!

banner motd ^CC

**WARNING**WARNING**WARNING**

####################

**WARNING**WARNING**WARNING**^C

!

line con 0

exec-timeout 5 0

login local

speed 115200

line aux 0

login

no exec

line vty 0 4

exec-timeout 5 0

privilege level 15

login local

transport input ssh

transport output none

line vty 5 15

exec-timeout 5 0

privilege level 15

login local

transport input none

transport output none

!

scheduler allocate 20000 1000

ntp clock-period 17179987

ntp source Serial0/0/0

ntp server ########

mohammedmahmoud Mon, 08/20/2007 - 06:06

Hi,

The reason is like Rick has stated earlier you must have "ip routing" command, one comment though, i doubt that this is a 3560 switch as 3560 has no serial interfaces.

HTH,

Mohammed Mahmoud.

mohammedmahmoud Mon, 08/20/2007 - 06:13

Hi,

Ok, perfect, just enter "ip routing" and it will work fine.

HTH,

Mohammed Mahmoud.

Richard Burts Mon, 08/20/2007 - 06:18

Ernest

Thanks for the clarification. The config (especially the serial interface) makes much more sense as a 2851 than it does as a 3560. Would you post the output of show protocol and of show version, and perhaps of show ip interface brief?

[edit] Mohammed I just saw your post. I believe the issue of "ip routing" is very likely if the device really was a layer 3 switch as we originally believed. If the device is a 2851 router then ip routing should be enabled by default. I am no longer sure that this is the issue.

HTH

Rick

mohammedmahmoud Mon, 08/20/2007 - 06:28

Hi Rick,

I totally agree with you, and more over i've checked one of my 2800 and ip routing doesn't appear in the sh run as a default configuration (i doubted when i didn't saw it in Ernest config thinking that it must appear, but no), and thus my assumption is that the interfaces are not up/up, and i think that Ernest shall clear this out for us.

HTH,

Mohammed Mahmoud.

Not sure myself, Note: I have 30 additional "2851" on my einterprise with the same basic configuration without this issue?

Show Protocal

Global values:

Internet Protocol routing is enabled

GigabitEthernet0/0 is up, line protocol is down

Internet address is X.X.X.X

GigabitEthernet0/1 is administratively down, line protocol is down

Serial0/0/0 is down, line protocol is down

Serial0/0/0.1 is down, line protocol is down

Internet address is X.X.X.X

Show Version

Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(1a),

RELEASE SOFTWARE (fc2)

ROM: System Bootstrap, Version 12.3(8r)T7, RELEASE SOFTWARE (fc1)

uptime is 6 days, 1 hour, 58 minutes

System returned to ROM by power-on

System image file is "flash:c2800nm-advipservicesk9-mz.124-1a.bin"

Cisco 2851 (revision 53.51) with 249856K/12288K bytes of memory.

Processor board ID FTX0935A1MC

2 Gigabit Ethernet interfaces

1 Serial(sync/async) interface

2 Virtual Private Network (VPN) Modules

DRAM configuration is 64 bits wide with parity enabled.

239K bytes of non-volatile configuration memory.

62720K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x3922

sho ip int br

Interface IP-Address OK? Method Status Prot

GigabitEthernet0/0 X.X.X.X YES NVRAM up down

GigabitEthernet0/1 unassigned YES NVRAM administratively down down

Serial0/0/0 unassigned YES NVRAM down down

Serial0/0/0.1 X.X.X.X YES NVRAM down

Richard Burts Mon, 08/20/2007 - 06:44

Ernest

The answer is in the output that you posted:

Serial0/0/0.1 is down, line protocol is down

The syntax of your static default route is correct. But if the interface that the static route points to is protocol down then the route will not be placed into the routing table. Therefore there currently is no Gateway of Last Resort. To get the Gateway of Last Resort into the routing table you need to resolve the issue with the Serial/Frame Relay connection.

HTH

Rick

Richard Burts Mon, 08/20/2007 - 07:10

Ernest

Given the information that you posted:

Serial0/0/0 is down, line protocol is down

Serial0/0/0.1 is down, line protocol is down

This is not an issue that can be fixed by no shutdown (as you have discovered) but is probably an issue with the physical connection. When a serial interface reports status of line is down that means that the interface is not seeing electrical signals from the interface. Either it is disconnected or whatever it is connected to is powered off (or some other similar type of problem). You need to address the connectivity problem. I do not see any evidence of a configuration problem. It look like a physical layer problem to me.

HTH

Rick

mohammedmahmoud Mon, 08/20/2007 - 07:15

Ernest,

Totally agree with Rick, this is a physical issue, make sure that your cables are well connected and review this with your provider, and once you have the serial interface up/up the route will be injected into the routing table.

HTH,

Mohammed Mahmoud.

Ok, That may be it... I hope so however, I never tested or tried the sho ip route command on a box that was/is not physically connected to anything. Which started me asking why the Gateway would not set? That would hold true of a layer one issue.

However, when it was physically connected to the network I couldn't or did not see it as well. So, I had the SA take it off to troubleshoot and this is where we are.

I'll have not made any changes to the config since it was removed....again puzzling that this id the only box I'm having this issue.

Richard Burts Mon, 08/20/2007 - 07:35

Ernest

I have tested this many times (and experienced it live more times that I wish to remember) and I am very positive that when an interface goes protocol down that any static route which is configured to use the interface will be withdrawn from the routing table.

The first thing to do is to restore connectivity on the serial interface (and its associated subinterface). I suspect that this will restore the default route to the routing table and establish a Gateway of Last Resort. If it does not then we can troubleshoot from that point.

HTH

Rick

Richard Burts Mon, 08/20/2007 - 06:26

Ernest

I do believe that the output of show protocol, show ip interface brief, and of show version would help us to understand this issue much better. Can you post them (If you are concerned about revealing the IP addressing then I suggest that you just alter the first octet of each address - to something else in that same address class - so that we will not see your real addresses but will be able to understand the relationships of addressing).

HTH

Rick

Actions

This Discussion