Converting CCME Cisco 7912 SIP Image to SCCP

Unanswered Question
Aug 16th, 2007
User Badges:

Hi,


Can someone direct me to the link to update the Image from SIP to SCCP on a 7912 IP Phone.


Also how do i get the idle URL to work on CCME. I have followed the procedure to edit the image for CCM. It works for CCM but not CCME.


Any ideas will be well appreciated, as I am running out of time to get this to work.


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Majdi Harb Thu, 08/16/2007 - 23:55
User Badges:
  • Silver, 250 points or more
p.holley Fri, 08/17/2007 - 07:06
User Badges:

Hi,


The phone is not currently registered with CME. I have a SIP phone that I will like to register with CME using SCCP. I was able to get this done with the 7940-60 SIP phones by editing the SIP 097XX.txt file with the new SSCP image for the 7940-60 phones.


I included the image for the 7912 phone, thinking it will upgrade to sccp but it failed.


Any ideas

paolo bevilacqua Fri, 08/17/2007 - 08:54
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


you need to prepare a gkdefault.cfg file to make the phone upgrade. All the instruction and necessary tools are in the bmp2logo file that you can download from CCO.

p.holley Fri, 08/17/2007 - 13:07
User Badges:

I prepared the gkdefault.cfg file. I have attached the txt format of several files that i tried using.



I copied the gkdefault.cfg file to flash, issued the tftp server flash:gkdefault.cfg and also the same command for the 7912 firmware. then i have the load 7912 configured on CME. sStill cannot get it to work.


help!!!





Attachment: 
paolo bevilacqua Fri, 08/17/2007 - 13:16
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, please place the IP address of the router in the 5th field, instead of 0.0.0.0

Also please set the 6th field to 0x060817A.

Note there is a more recent version of FW for the 7912, 8.0(3) that I suggest you to use.


Finally observe the upgrade process with "term mon" and "debug tftp events".

p.holley Sat, 08/18/2007 - 12:33
User Badges:

Hello,


I know have the following field in the gkdefault.cfg file


#txt


upgradecode:3,0x601,0x0400,0x0100,192.168.10.250,0x060817A, 0x030829a,CP7912080003SCCP070409A


I then have the gkdefault.cfg in flash and have the tftp-server flash:gkdefault.cfg

i also have tftp-server flash:CP7912080003SCCP070409A.sbin and also have the FW in flash


Then i have load CP7912080003SCCP070409A


Still not working for me. Running CME4.1 IOS 12.4(11)XJ3.


Thanks

paolo bevilacqua Sat, 08/18/2007 - 12:40
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


the above is not correct, you have an extra field: 0x030829a, remove it. Alos add .bin in filename (last field)


Place that in a file called gkdefault.txt.


then on the pc execute "cfgfmt gkdefault.txt gkdefault.cfg"

copy gkdefault.cfg into the router and the phones should upgrade.

Maker sure you have option 66 with the address of the router in your dhcp config.


If still problems please post here the output of "term mon' and "debug tftp-events".

paolo bevilacqua Mon, 11/19/2007 - 11:42
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


Which example would you like to see? One to convert to SIP image ?

paolo bevilacqua Fri, 08/17/2007 - 03:05
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, for the 7912, log into download area for voice, "client tools", download 'bmp2logo.zip' and follow the instructions in the files inside.


Hope this helps, please rate post if it does!


Actions

This Discussion