QOS

Unanswered Question
Aug 17th, 2007
User Badges:


We have two T1 lines coming to router from ISP and configured three vlans on the same router.



My question:-


We want to dedicate 2.5Mbps bandwidth for one vlan and remaining bandwidth for other two vlans. Incase one vlan not using 2.5Mbps bandwidth remaining should go for other vlans.


Do you know the configuration to configure the above requirements?


Regards,

Khan


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jwdoherty Fri, 08/17/2007 - 07:07
User Badges:

Assuming you want to do outbound and the dual T1s are bundled, yes you can with CBWFQ.


Something like:


policy-map CBWFQ

class vlan1

bandwidth 2500


You will need a class map that recognizes traffic from vlan1.


Inbound is very ugly unless you can do it on the wan router. Then similar to above.

azmath.hk Fri, 08/17/2007 - 07:40
User Badges:

Perfect!!



Incase vlan1 not using 2500 bandwidth will it be avalibale for other vlans on router?


can you tell me the configuration for inbound traffic as well?





Pavel Bykov Fri, 08/17/2007 - 08:18
User Badges:
  • Silver, 250 points or more

Agree with jwdoherty.


1. Yes, it will be available for other VLANs. That's how CBWFQ work (unless you use policing/shaping in connection with class-maps)


2. It's not that easy for inbound. All the congestion management systems work with software queues that are inside the router. For input traffic, the queues are different, since all data is sent at LINESPEED and queues are created only in case of abnormal router utilization and/or Multiaccess medium.


The best way would be to create same QoS setup on the other side. You would have to contact your ISP and ask about applying QoS maps on their output interfaces. ISPs sometimes do that for a not-too-high fee. You cannot even use shaping on input, and your available choices will be very dependent on your router model.



EDIT:

As a rule of thumb, your primary control point is output, and input control work mostly as support. Some platforms have interesting options, like 2 priority queues, where you would put your important VLAN in one queue and all other VLANs into other queue.



What box do you have?

E.G. 2851 cannot have input priority queue. But it can police (hard-limit) the incoming traffic, which is probably not what you want.



Here is one possible setup:

OUT:

ip access-list extended out-vlan

permit ip VLAN_SUBNET VLAN_MASK any

class-map match-any important

match access-group out-vlan

policy-map control-out

class important

bandwidth 2500

class class-default

fair-queue


IN:

ip access-list extended in-vlan

permit ip any VLAN_SUBNET VLAN_MASK

class-map match-any unimportant-in

match not access-group in-vlan

policy-map control-in

class unimportant-in

police XXX (XXX is the maximum rate all other VLANs will be able to use)



Then apply it to the interface:

service-policy input control-in

service-policy output control-out



You would be much better off contacting the ISP and persuading them to apply output map.


Hope this helps.

Please rate all helpful posts.

azmath.hk Fri, 08/17/2007 - 09:03
User Badges:

Thank you very much for your help..


But the problem is I cannot apply this service-policy on sub-interface.


Is there any way we can apply the same on sub-interface.


Please help me

azmath.hk Fri, 08/17/2007 - 09:13
User Badges:

We have 2600 router and created sub-interfaces as vlans.. see my last input for more information

jwdoherty Fri, 08/17/2007 - 09:17
User Badges:

Sub-interfaces on the LAN side or WAN side? You want to put the policy on the WAN interface.

azmath.hk Fri, 08/17/2007 - 09:36
User Badges:

sub-interface on the LAN side...because this is where we want to priortize the traffic...


on serial interface 1 and 2 T1 lines are connected...how we can do that on wan side?


we want to do this on vlan basis

jwdoherty Fri, 08/17/2007 - 09:41
User Badges:

See Pavlo's post as an example. He's is assuming you can identify VLAN1 traffic by address block.

Actions

This Discussion