Configuring 1DSU-T1 on Cisco 1720

Unanswered Question
Aug 18th, 2007
User Badges:

Hello,


I'm playing with a couple of Cisco 1720's and trying to make them work. Each of them has 1 WIC 1DSU-T1 (http://www.cisco.com/en/US/products/hw/routers/ps221/products_data_sheet09186a00801a9184.html)


I reset both routers and configured onboard FastEthernet interfaces. However, I'm confused about these WIC's. They show up as Serial interfaces and I cannot bring them up.


I tried connecting them to each other and to a laptop via regular CAT5 cross-over cable, but all it shows is


Interface IP-Address OK? Method Status Prot

ocol

FastEthernet0 192.168.3.103 YES manual up down

Serial0 10.0.0.2 YES manual down down


(routers' configuration is provided below)


My questions are:

1. What am I doing wrong? Do I need to set up clock rate, etc for this "serial" interfaces?

2. Can I troubleshoot these 1DSU-T1 WIC's with a cross-over cable and a laptop at all? (Linux 2.6.8 with regular Ethernet interface)


Thanks in advance for any help!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
scarabey_ Sat, 08/18/2007 - 16:42
User Badges:

P.S. Here's the routers' configuration:


test1#show interfaces serial 0

Serial0 is down, line protocol is down

Hardware is PQUICC with Fractional T1 CSU/DSU

Internet address is 10.0.0.1/24

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set

Keepalive set (10 sec)

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 3 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=down DSR=up DTR=up RTS=up CTS=down


test1#show running-config

Building configuration...


Current configuration : 601 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname test1

!

!

!

memory-size iomem 25

ip subnet-zero

!

!

!

!

interface Serial0

ip address 10.0.0.1 255.255.255.0

no fair-queue

!

interface FastEthernet0

ip address 192.168.2.104 255.255.255.0

speed auto

!

ip classless

ip http server

!

!

line con 0

login

line aux 0

line vty 0 4

login

!

end


------------------------------


test2#show interfaces serial 0

Serial0 is down, line protocol is down

Hardware is PQUICC with Fractional T1 CSU/DSU

Internet address is 10.0.0.2/24

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set

Keepalive set (10 sec)

Last input never, output never, output hang never

Last clearing of "show interface" counters 00:15:29

Queueing strategy: fifo

Output queue 0/40, 0 drops; input queue 0/75, 0 drops

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 6 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=down DSR=up DTR=up RTS=up CTS=down



test2# show running-config

Building configuration...


Current configuration:

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname test2

!

!

!

!

!

memory-size iomem 25

ip subnet-zero

!

!

!

!

interface Serial0

ip address 10.0.0.2 255.255.255.0

no fair-queue

!

interface FastEthernet0

ip address 192.168.3.103 255.255.255.0

speed auto

!

ip classless

ip http server

!

!

line con 0

login

transport input none

line aux 0

line vty 0 4

login

!

no scheduler allocate

end


Richard Burts Sun, 08/19/2007 - 04:30
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

The biggest problem is your crossover cable. An Ethernet crossover will cross 1, 2 and 3, 6 but a T1 serial crossover will cross 1, 2 and 4, 5. You can not use standard Ethernet crossover to connect serial interfaces.


Once you get a correct crossover cable you will also need to configure one of the routers for clocking internal and to configure a clock rate.


HTH


Rick

Richard Burts Sun, 08/19/2007 - 19:10
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

You are quite welcome. Thank you for the rating.


HTH


Rick

rseiler Mon, 08/20/2007 - 11:55
User Badges:
  • Silver, 250 points or more

The correct command to see the status of the physical serial port is 'show controller serial'.


Also, the status of the T1 DSU is seen with the command 'show service-module'.


Please note that a Cat5 patch cable may short-out one or both of the CSU's if used to connect back-to-back.


Be sure to *only* use a cable with pins 1,2,4 and 5 connected. *DO NOT* cross-connect *any* other pins!!! A T1 should specifically *not* be grounded on pins 3 or 6, particularly between 2 cross-connected routers.

Actions

This Discussion