CCM PG not coming up

Unanswered Question
Aug 19th, 2007

Hi,


I have a small hosted IPCC lab and right now I am trying to configure the CCM PG but I see the following two messages every 30 seconds in the opc window:

13:47:54 Sending initialize PG Agent request - ActiveState=3 Present=1,0 Side=A.

13:48:24 Timeout initializing PG Agent, Activate=3.


Any Idea please? Appreciated.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
halmaktoum Sun, 08/19/2007 - 10:51

On what port do the PGs and ICM communicate? I might have a problem with port configuration on the ICM box. I noticed that I also have the exact problem with the ISN PG.

halmaktoum Sun, 08/19/2007 - 23:18

Hi Geoff,


No it says IDLE. here is the output of the jtapigw:


16:23:38 Trace: Release 7.0.0.0 , Build 14833

16:23:38 Initializing Node Manager Library.

16:23:38 Trace: Display of EMS messages to the screen has been dynamically disabled.

16:23:40 Trace: Display of EMS messages to the screen has been dynamically disabled.


Regards,

Han

lpezj Sun, 08/19/2007 - 23:35

Hi,


It is important that you active the output trace on the jtapigw process.


Change this registry key and post the output process:


HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\\PG1A\EMS\CurrentVersion\Library\Processes\jgw1


and chage the 'EMSDisplayToScreen' from 0 to 1.


Hope this helps,


Juan Luis

halmaktoum Mon, 08/20/2007 - 00:52

Hi Juan,


Thanks. I have changed the key and can see the output on the screen now. here is the output:


11:48:41 Trace: Not using CiscoSynchronousObserver interface.

11:48:41 Trace: Initializing JTAPI TraceManager.

11:48:41 Trace: disableAll() TraceManager for CTICLIENT

11:48:41 Trace: Calling getProvider() 100.1.1.20;login=ccmpguser;passwd=<***edited***>

11:48:42 Trace: Returned successfully from getProvider()

11:48:42 Trace: disableAll() TraceManager for CTICLIENT

11:48:42 Trace: Waiting for the provider to be in service

11:48:42 Trace: ProvInServiceEv

11:48:42 Trace: Provider is in service

11:48:42 Trace: Creating Instruments for 2 addresses

11:48:42 Trace: JTapiServer: Wait for adding CallObservers to 2 addresses

11:48:42 Trace: ThreadAddressManager: Adding AddressObservers to 2 addresses

11:48:42 Trace: Call to address.addObserver for 2002 returned successfully after 141 milliseconds

11:48:42 Trace: CiscoAddrOutOfServiceEv Addr: 2002 Cause: NORMAL

11:48:42 Trace: CiscoAddrInServiceEv Addr: 2002 Cause: NORMAL

11:48:42 Trace: CiscoAddrOutOfServiceEv Addr: 2001 Cause: NORMAL

11:48:42 Trace: Call to address.addObserver for 2001 returned successfully after 0 milliseconds

11:48:42 Trace: [Thread-1]ThreadAddressManager ends adding observers after 141 milliseconds

11:48:42 Trace: ThreadAddressManager::processNextQueuedMsg: msgHashtable.size = 0

11:48:42 Trace: ThreadAddressManager::Waiting for next retry

11:48:42 Trace: JTapiServer: Complete waiting for adding CallObservers to 2 addresses

11:48:42 Trace: Successfully configured JTAPI Object.

11:48:42 Trace: Creating server socket on port 40029 to listen for PIM connections.

11:48:42 Trace: CiscoAddrInServiceEv Addr: 2001 Cause: NORMAL


Regards,

Han

nurulchoudhury Sat, 10/23/2010 - 03:02

Hi Han,


I was also facing the same issue with the same error message. In my case the issue was I have not selected the PG in the DMP while installing the Router.


In your case you can check this from the registry Router -> DMP->Device -> PG enabled or disabled. If disabled then enable it by running Router setup.



Regards,

Nurul.

Actions

This Discussion