Tacacs+ "Error in authentication"

Unanswered Question
Aug 20th, 2007
User Badges:

Hi,


I had configured C3560 switch running Version 12.2(25)SEB4 to authenticate telnet session against ACS SE 4.1 (Tacacs+).


I encountered a problem once I issued the command

** aaa authentication enable default group tacacs+ enable **


the enabled password not accepted and I got the error "% Error in authentication." I checked out the reports on ACS for failed auth and here the error "ACS password invalid".


I removed the command and things going fine but with local enable password.


Configured commands:


aaa authentication password-prompt Password:

aaa authentication username-prompt Login:

aaa authentication login TELNET group tacacs+ local

aaa authentication login CONSOLE none

aaa accounting exec TELNET start-stop group tacacs+

aaa accounting network TELNET start-stop group tacacs+

line vty 0 4

login authentication TELNET



any suggestion !!


Regards,

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
rochopra Mon, 08/20/2007 - 03:02
User Badges:
  • Cisco Employee,

Hi,


When using:


aaa authentication enable default group tacacs+ enable


You are implementing enable authentication through TACACS. Make sure that you have "TACACS enable options" properly configured for user in ACS.


-->By default "use seperate password" is selected with blank password.

Set it to use pap password for using the user password as in ACS, if user is in external database then use the second option to use external db password, else use seperate password and define a password.


* if you are not able to see these options in user setup, enable it from interface configuration > TACACS+ (Cisco) > Advanced TACACS+ Features


Hope this helps.


~Rohit

balsheikh Mon, 08/20/2007 - 03:43
User Badges:


Hi Rohit,


thx for ur replay, its working fine but ONLY per user (i.e through user setup), I have LDAP DB and all credentials reside over there, therefor i need to configure it globally in group setup (mapped group to LDAP group).


I didn't find the "TACACS+ enable options" on group setup, what is the best feasible way to implement it !!


appreciate ur soonest feedback..


regards,

Belal

balsheikh Mon, 08/20/2007 - 04:43
User Badges:


I think I'll be lost if I go through the RDBMS sync.


anyway, thx for ur support.

Actions

This Discussion