FastEthernet0/0 is up, line protocol is down!

Answered Question
Aug 20th, 2007

Hi,

I have an issue with a router's fast ethernet interface. The Interface says it is up, but line protocol is down. I have tried several times to get the line protocol up but i some how just cant get it to start.

Please see attached config file for the config of the router.

Any assistance will be welcomed please.

I have this problem too.
0 votes
Correct Answer by Richard Burts about 9 years 3 months ago

Femi

You say: "I believe that if the Interface is up, then the cable must be plugged in". That is an incorrect assumption. In my experience when a cable is not plugged in the Ethernet/Fast Ethernet will show to be line up line protocol down, which is the exact symptom that you report. I suspect that if someone physically checks the connection that they will find that the interface is not connected to a switch or anything.

HTH

Rick

Correct Answer by b.petronio about 9 years 3 months ago

That what i was suspecting, since the description says, "LAN".

Did the router send any log messages ?

Try, like someone sayed several configurations port speed/duplex. Starts with a auto/auto.

If that dont result, check cabling to switch.

If that dont result, check if the users on the switch could ping each other. If they could not do it, u may have a malfunction switch.

http://www.cisco.com/en/US/products/ps5853/products_configuration_guide_chapter09186a0080458413.html

"Fast Ethernet n is up, line protocol is down":

- "The specified Fast Ethernet interface has been correctly configured and enabled, but the Ethernet cable might be disconnected from the LAN."

Hope i have helped

Best Regards,

Petr?nio

Correct Answer by krishnakomiti about 9 years 3 months ago

Hi,

Check with cable is connected or not, if cable is connected properly and check with the ISP people wheather they have connected properly or not (max problem with the ISP side. call ISP people check the status from them.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (5 ratings)
Loading.
Correct Answer
krishnakomiti Mon, 08/20/2007 - 01:05

Hi,

Check with cable is connected or not, if cable is connected properly and check with the ISP people wheather they have connected properly or not (max problem with the ISP side. call ISP people check the status from them.

royalblues Mon, 08/20/2007 - 01:12

Try changing the speed and the duplex settings on the switch and see whether the link comes up

Narayan

kelloggs4life Mon, 08/20/2007 - 01:19

Hi,

I am working remotely on that router in question. I believe that if the Interface is up, then the cable must be plugged in. But just to crosscheck, i have sent someone to the site to check and make sure the cable is indeed plugged in.

For your information, the cable connects directly to the LAN in that remote office through a switch.

Correct Answer
b.petronio Mon, 08/20/2007 - 01:36

That what i was suspecting, since the description says, "LAN".

Did the router send any log messages ?

Try, like someone sayed several configurations port speed/duplex. Starts with a auto/auto.

If that dont result, check cabling to switch.

If that dont result, check if the users on the switch could ping each other. If they could not do it, u may have a malfunction switch.

http://www.cisco.com/en/US/products/ps5853/products_configuration_guide_chapter09186a0080458413.html

"Fast Ethernet n is up, line protocol is down":

- "The specified Fast Ethernet interface has been correctly configured and enabled, but the Ethernet cable might be disconnected from the LAN."

Hope i have helped

Best Regards,

Petr?nio

Correct Answer
Richard Burts Mon, 08/20/2007 - 02:54

Femi

You say: "I believe that if the Interface is up, then the cable must be plugged in". That is an incorrect assumption. In my experience when a cable is not plugged in the Ethernet/Fast Ethernet will show to be line up line protocol down, which is the exact symptom that you report. I suspect that if someone physically checks the connection that they will find that the interface is not connected to a switch or anything.

HTH

Rick

royalblues Mon, 08/20/2007 - 03:04

I agree with Rick.

When you do a no shut to an ethernet interface it will show up even though no cable is connected to it

Narayan

kelloggs4life Mon, 08/20/2007 - 06:28

Hello Rick,

You are totally right. Some "genius" removed the cable to the LAN from the fast ethernet port without my permission.

Thanks all for your contribution. You were all really helpful.

Cheers

Femi

Richard Burts Mon, 08/20/2007 - 06:35

Femi

I am glad to know that my analysis of the symptom was helpful. Thanks for updating this thread and indicating the solution to the issue (and thanks for the rating). It makes the forum more useful when people can read about an issue and can read the successful resolution of the issue. I encourage you to continue your participation in the forum.

HTH

Rick

b.petronio Mon, 08/20/2007 - 06:38

... and rate all the people that help u to resolve ur problems ...

ehehehe... :)

Best Regards,

Bruno Petr?nio

Actions

This Discussion