Cisco ACS 3.3.2 to 3.3.4 Upgrade Problem

Unanswered Question

I'm trying to upgrade from 3.3.2 to v3.3.4 on a Windows 2000 server (SP4) and everytime I run the update it gives me a message about half way through:

"The CiscoSecure ACS folder appears to be locked by another application

C:\Program Files\CiscoSecure ACS v3.3

Please close any applications that are using any files or directories in this folder and re-run Unintstall. Note: you should also close any Explorer windows using the folder."

I've rebooted the server and tried the upgrade over 3 times including shutting down very service on the system I could without any luck. Any suggestions to get the 3.3.4 upgrade installed on this machine?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
rochopra Mon, 08/20/2007 - 17:23

Hi,

Move logs from the following folders to different location (outside ACS install folder):

\CSAdmin\Logs

\CSAuth\Logs

\CSDBSync\Logs

\CSLog\Logs

\CSMon\Logs

\CSRadius\Logs

\CSTacacs\Logs

It will allow you to move all logs except latest one.

Once moved then try to upgrade it should work fine.

If still facing issues try to disable antivirus or script blocking software, then try to upgrade.

Hope this helps.

~Rohit

darpotter Tue, 08/21/2007 - 01:23

As a precautionary step I would always set all the CSxxx services to manual start and then reboot the server BEFORE doing an upgrade.

That way there are no issues with running services to get in the way. Sometimes this can cause issues.

rochopra Wed, 08/22/2007 - 14:39

Please mark thread as resolved so that others can benefit from it.

~Rohit

Actions

This Discussion