CSA uninstall problem after upgrade to CCM 4.2.3

Answered Question
Aug 21st, 2007

I upgraded a CCM to version 4.2.3 but I didn't uninstall the old version of Cisco Security Agent before.

When I tried to install the new one (CiscoCM-CSA- after the upgrade, I received the message "Unable to obtain the product id for the standalone agent. Setup will now abort". I found that it means that I have to uninstall the old version before installing the new one.

When I tried to uninstall the old version, I received "Stopping service Cisco Security Agent failed. Aborting installation".

Is there an entry to kill in the registry or something else?

Thx in advance,


I have this problem too.
0 votes
Correct Answer by pklos about 9 years 2 months ago

new CSA is: CSA-CiscoCM-CSA-

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
jbarcena Tue, 08/21/2007 - 07:24

Try stopping the CSA service manually and then set it to disable. Then attempt to uninstall the CSA.



Correct Answer
pklos Tue, 08/21/2007 - 07:25

new CSA is: CSA-CiscoCM-CSA-

francois.staiesse Wed, 08/22/2007 - 04:10

I restarted the CSA service, I tried to install the latest version (CSA-CiscoCM-CSA- and it was ok.

Many thanks for you help!


francois.staiesse Tue, 08/21/2007 - 07:38

It's already done. I disabled it in Windows services.

Don't I have to delete an entry in the registry?

jbarcena Tue, 08/21/2007 - 07:40

No, you shouldn't need to do that. That is something that the uninstallation will do.

francois.staiesse Tue, 08/21/2007 - 07:48

Yes but there is no way to do this manually? The service is stopped and disabled, and when I try to uninstall, I receive "Stopping service Cisco Security Agent failed. Aborting installation".

mchandak Tue, 08/21/2007 - 07:53

Do you get the same error when the service is set to Automatic and started. The installer is trying to stop CSA, but since it is already stopped and disabled, it seems to fail. Un-installing CSA with the service running.

francois.staiesse Tue, 08/21/2007 - 10:26

I tried to uninstall CSA when the service was running and I received the same error message.


This Discussion