Ethernet protocol down, will not come up

Unanswered Question
Aug 21st, 2007
User Badges:

I upgraded the flash card on an 871W and now the ethernet interfaces will not come back up. I had done the same thing with another 871W, upgraded the flash, then ran a tftpdnld from rommon to get the IOS back and had no issues. I have been around and around, most recently putting the orginal flash card back in and reloading the IOS through xmodem (painfull). I can get the IOS to boot up okay, but the ethernet interfaces still are OK up protocol down. I have a known good cable. I have tried using the no-keepalive command as well, still nothing. I have erased the flash again and I am reloading again with xmodem in the hope that I can figure this out, but I think this problem is bigger than I am!

I will post the running-config when I have the IOS loaded again, but any thoughts in the meantime would be quite welcome.


Mark

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 2.8 (4 ratings)
Loading.
Richard Burts Tue, 08/21/2007 - 13:58
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Mark


In most of my experience an Ethernet that shows to be line up and line protocol down has turned out to have some problem with the connection.


I would suggest that you check the connection carefully for some physical problem (and perhaps for a speed mismatch). If you do not find anything like that then please do post configs when the IOS is loaded again.


HTH


Rick

cybrsage Tue, 08/21/2007 - 13:58
User Badges:

It could be that your old config has become corrupt and needs to be cleared and re-entered.


If you have a good copy of the config, save it to a txt file and open with notepad. This way, you have your old config to copy and paste with.


You can then do a wr erase to erase the startup config from the device and reboot, being careful to say no to any "config has changed, save?" questions.


When it comes back up, it will be in the cleanest state possible. Skip the setup wizard and just paste back in your old config.


mnleblanc Tue, 08/21/2007 - 14:59
User Badges:

Gentlemen, thank you for your responses. I have attached the boot sequence and running-config for your scrutiny. I have things pretty much at square one now. Again, the CAT5 cable is known good, the laptop nic works, etc. I am suspicious of the fact that all the Ethernet interface lights are solid green with nothing plugged in, but I have a twin to this unit at home that I will check after work.


Thanks again,

Mark



Attachment: 
Richard Burts Tue, 08/21/2007 - 17:39
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Mark


I have looked at the file that you posted and am not sure that I see anything out of the ordinary in it other than the fact that the version of IOS that you are loading is a deferred image due to problems that Cisco has observed in it. Cisco is recommending 12.4(4)T8 instead. But I am not sure that this is the issue.


Can you verify for us which port the PC is plugged into? And can you verify what kind of CAT5 cable is used (straight through or cross over)? And can you confirm that both ends of the cable are firmly and completely connected?


HTH


Rick

mnleblanc Tue, 08/21/2007 - 18:42
User Badges:

Rick,


Thanks for taking the time to look over this config. I am home now, (EDT) but to answer your questions:


I was using a straight through cable, (known good) and connecting my laptop to the fa0 LAN port. The laptop was on 115v so the NIC was not on power save. The RJ45s gave me a crisp click on insertion.


I used the same laptop on my 871W at home and the NIC came right up when I plugged into fa0.


One difference I did notice physically is that for some reason all four fastethernet interface LEDs on the malfunctioning 871W at work are remaining lit, while at home only active interface LEDs are illuminated, as expected.


I have been guilty of over looking the obvious before, but this just isn't jumping out at me.

Mark

mahmoodmkl Wed, 08/22/2007 - 01:19
User Badges:
  • Gold, 750 points or more

Hi


U need to use a cross-over cable to connect u r laptop to ur router ehternet port.


Thanks

Mahmood



mnleblanc Wed, 08/22/2007 - 02:34
User Badges:

Mahmood,


Thank you for your suggestion. I have tried a crossover cable, however the 871W is a broadband router with an integrated switch and the crossover cable should not be necessary in this case. I have another 871W that works fine with a straight through cable.


Again, thanks for your suggestion,

Mark

mnleblanc Thu, 08/23/2007 - 15:04
User Badges:

After contacting TAC and letting them review my issue, they decided to replace the 871W.


Thanks for assistance.


Mark

Actions

This Discussion