Multicast and Ghosting

Unanswered Question
Aug 22nd, 2007

Ghosting to multiple workstations using the software Ghost used to work perfectly. Now it has stopped working. It does work with unicast.

The only change I can think of is that we upgraded out core switch from CatOS to CiscoIOS.

Can this affect multicast.

What can I check to get this working again?

Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Wed, 08/22/2007 - 04:55

Hi

Are you multicasting across vlans or within the same vlan.

if across vlans you need to ensure you have turned on multicast-routing and enabled pim on the relevant vlan interfaces.

If only local vlan you need to enable igmp snooping on the switch and you will need to make it an "igmp querier" as well.

What does output of "sh ip mroute" show.

Jon

londint Mon, 09/03/2007 - 05:59

Thanks.

It is across VLAn and yes pim and multicast is enabled on the necessary interfaces. Also cgmp is enabled on the Switches.

But it still does not work.

Thanks

cratejockey Mon, 09/03/2007 - 18:07

You have tapped into the real black arts of networking now :) I have been implementing and troubleshooting Multi cast for Imaging in an OS X environment for about the last year.

Here is what I have found:

If your Core Switch natively supports IGMP make sure that CGMP compatibility is enabled. By default it is not.

Once you are pretty sure that PIM, IGMP, CGMP and Multi cast routing are configured properly then use a verifiable multi cast source and receiver. I recommend VLC Media Player on both sender and receiver sides. Make sure that you have a video that you can stream then set the sender up in one VLAN and use the Streaming Wizard to configure and start a multi cast stream with a minimum TTL of 5. From there go to your receiver in another VLAN and set it up to view a multi cast stream, which you can do from the Open menu. Once this is done you should see and here the video via multi cast. Make sure it is long enough that you can pull statistics off of your switches and get a good feel for what it does on the network.

If the video test works then multi cast routing is fine. If Ghost continues not work work it could be some other problems including portfast not being enabled, ip helper addresses not set correct, speed and duplex issue or ghost server/client config issues.

On the Ghost side make sure your TTL is at least 5 that comes from TAC when we were fighting this issue initially.

Let me know how this turns out I can help out with lots of issues pertaining to Multi Cast imaging.

Good Luck.

www.staticnat.com

s.gilbrook Tue, 09/04/2007 - 08:12

Hi,

I am also in the process of trying to get a Ghost setup working across multiple VLAN interfaces (I can get Ghosting to work OK within the same VLAN, as well as streaming as per your VLC tests).

I am using 2 x 4507R's and have attached the interface configurations. I have globally enable d ip multicast routing on both 4507's, as well as enable IGMP snooping on the connecting 2950 switches, but for some reason I can still not see ghost/VLC streams from different VLAN's.

If you could give me some pointers on mcast that would be handy !

Thanks.

cratejockey Tue, 09/04/2007 - 09:26

I just did a quick look at your config and it looks pretty good. However I noticed that you do not have an IP Helper Address. Do you have a DHCP server on every VLAN? If not this could be part of the issue you are having with Ghost if clients cannot get IP addresses. If you want me to take a closer look send me one of your edge switch configs as well as Core config you already sent.

later,

www.staticnat.com

s.gilbrook Wed, 09/05/2007 - 05:06

Thanks for taking a look - the Ghost server is currently the only DHCP service that we use and only issue IP's to hosts (Ghost clients) withinin the Ghost VLAN (899).

As it happens I tried the VLC stream test again today across two sepeart VLAN interfaces and it seemed to work. I haven't tried the Ghost mcast yet so that's the next thing to try.

I think the problem was that both of the 4507's had not had the snooping commands set for VLAN 4 when I tested yesterday, but since applying these configs VLC seems to work OK.

Thanks for the help.

londint Wed, 09/05/2007 - 04:22

Thanks

As per the ip helper address issue, using Ghost via unicast on different vlans work but not using multicast. Will enabling ip helper work for multicast and why should it work?

Thanks

cratejockey Wed, 09/05/2007 - 05:23

I would need to see more of your config before I could really address this issue. A small diagram would be helpful also. Ghost via unicast is a whole different beast than Ghost via multicast.

By their nature VLANS should not allow DHCP requests destined for other network segments because it is broadcast traffic. In order to get an DHCP address in a vlan that does not have a dhcp server you should be using helper addresses to convert the broadcast DHCP stream to a unicast stream at the router interface. This will allow your clients to pull a DHCP address than participate in IP communications as what ever level. As far as you not needing it for unicast imaging that doesn't make since unless you are assigning static addresses to you clients.

Try to get your configs out there as well as a diagram.

www.staticnat.com

Actions

This Discussion