IP MULTICASTING across ATM not happening with PIM SPARSE

Unanswered Question
Aug 22nd, 2007

Hello

Iam running an enterprise network on which Iam trying to enable multicast routing. My IGP is OSPF.

I have e1 links from central noc to tier 1 locations and to tier 2 locations. Multicasting is fine upto this location

Multicasting is not getting through to Tier 3 lcocation which is connected to Tier 2 . The device involved is cisco 878 . Iam configuring the controller on these devices for atm mode and iam running ospf on the atm interface and vlan interface availbe on these device.

PIM neighbourship was not coming up across ATM interface. I created a gre tunnel to bring up the pim by enabling ip pim sparse mode neighborship . Now the pim neigborship is up via tunnel interface. But multicasting is not happening through this interface.

iam doubting this is because on the remote end device if i try to display sh ip route iam seeing the gateway interface as atm0 for the whole network prefix range and not tunnel interface.

The application iam using is video streaming from a linux server (vlc) from central noc.

Any help is appreciated.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Harold Ritter Wed, 08/22/2007 - 11:14

Parthiban,

You need to configure an ip mroute so that the source ip address (and the RP address) are resolved via the tunnel interface rather than the ATM interface.

ip mroute 255.255.255.255 tu0

ip mroute 255.255.255.255 tu0

Hope this helps,

parthibanp Thu, 08/23/2007 - 03:55

Hi hritter

Thanks for your update.

I tried after configuring this static mroute command.

Now iam able to ping the multicast group which I have configured on the ethernet interface to join at the leaf node router from my RP as well as from the next hop router.

But still the video iam streaming from the noc to a multicast ip could not be played on the cliet machine connected to the leaf node router (cisco 878).

I will try to attach the config of both side cisco 878 config.

Any suggestion awaited

Regards

Parthiban

Harold Ritter Thu, 08/23/2007 - 05:11

Parthiban,

This could be a TTL issue. I know VLC allows you to set the TTL on video stream multicast session. From your diagram, you would need a TTL of at least 5 to get to the remote location. What TTL value are you currently using?

Regards,

parthibanp Thu, 08/23/2007 - 20:12

Hi Hritter

Thanks for the follow up and response

I have been using a ttl of 16. But Iam wondering in ip pim sparse mode iam configuring auto rp and announcing the same at the noc router and configuring the same as mapping agents.

The rp information is not learnt at the Tier 2 router which is connected to Tier1 either on ethernet or in some cases on e1. Only these routers learns RP if i configure the Tier-1 routers as mapping agents.

Please clarify if a router is not directly connected to RP a mapping agent is must for learning RP

Once i configure Tier 1 routers as mapping agents the Tier-2 routers learns the RP.

Where as this doesnt happen at all in the case of cisco 878 both on the CO side where it connects to TIER-1 on ethernet aswell as on the CP side across ATM interface.

After refering a case study from jeff doyle yesterday i feel there are some mistakes on the tunnel configuration. So planning to make these changes today .

I will attach the config today for your reference

Regards

Partiban

parthibanp Fri, 08/24/2007 - 02:46

Hi Hriter

Please find the config attached.

Please clarify should I use the loopback interface as the source address for tunnel interface or the vlan interface.

If any changes u feel to be done let me know the same.

Attachment: 
Harold Ritter Fri, 08/24/2007 - 05:08

Parthiban,

Looking at your config I can see a few things that should be changed.

1) You should not really need to configure a tunnel interface between the two routers if you configured an ATM point-to-point subinterface. This should make your configuration much simpler.

2) RP will not be learnt via auto-rp if you don

Hope this helps,

parthibanp Sun, 08/26/2007 - 09:01

Hritter

Configuring point-to-point solved the issue finally.

Thanks for your timely suggestions.

Thanks a lot

Pavel Bykov Sun, 08/26/2007 - 11:19

Hello Parthiban.

What exactly have you configured for point-to-point operation to enable correct operation of multicasts?

Thanks.

Actions

This Discussion