2950 running constantly at 92% memory usage

Unanswered Question
Aug 22nd, 2007


We have several WS-C2950G-48-EI switches running IOS Version 12.1(11)EA1 that run at 92% memory usage constantly.

They seem to have been doing this for sometime and not causing any problems but solarwinds now reports on memory usage and I can see this being the first question I am asked when my manager sees the report.

Is it normal for them to run at such high usage 24\7 even overnight when hardly used?

Thanks for any help\advice,


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
frekes Wed, 08/22/2007 - 04:42


As a first off, without knowing more about what the switch is doing its difficult to say whether high memory utilisation is to be expected or not. Having said that you should save the output from a show tech and enter it into the output interpreter and see what it comes back with.

You may find you are running a known "buggy" version of IOS that has specific memory leaks which results in high utilisation.

It usually makes some suggestions for further monitoring to understand the cause behind the high utilization.

Its usually a good starting point. If the switch is running fine, and has always experienced this level of utilisation then its unlikley to be a problem and could just be a feature.



spiritgroup Wed, 08/22/2007 - 05:07

Thanks - have just done as you suggested and it has given me a lot to go and have a look at.

I didn't realise you could paste in an entire show tech into that tool.

Thanks for your help,



This Discussion