DFM Error after changing security permissions

Unanswered Question
Aug 22nd, 2007

I changed some security permissions of the group "users" by accident and got now the folloging error in the windows event viewer:

Event Type: Error

Event Source: InCharge

Event Category: (1)

Event ID: 16640

Date: 22.08.2007

Time: 23:06:47

User: N/A

Computer: CWSERVER


The description for Event ID ( 16640 ) in Source ( InCharge ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: [22-Aug-2007 23:06:47+453ms] [email protected]

SVIF-E-ESOCKETREGISTER-While attempting to register the server 'DFM' with the


SVIF-EBROKER-Cannot connect to DM Broker at 'cwserver:9002/dmbroker'

SM-EREFUSED-No process is connected to the specified location


DFM has all devices in learing state, but did not process them.

I could not find any useful information in the logs. Any ideas what to do?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Joe Clarke Wed, 08/22/2007 - 14:48

I assume you have since reverted your changes to the Users group. If the problem still persists after doing that, shutdown dmgtd, and look at the output of netstat -a. The TCP port 9002 must be available in order for the DFM broker to bind to it. If not, use netstat -a -o -b (Windows 2003 SP1 or later only) to see which process is bound to the port, and stop that process.

If the port is free, check the status of the DfmBroker process in the output of the pdshow command. Make sure it is running. If not, look at the NMSROOT\objects\smarts\local\logs\brstart.log to see if there are any obvious errors in there.

t.kraemer Thu, 08/23/2007 - 01:58

It seems that DfmBroker does not start. Brstart.log has no entries since I changed the permissions. Telnet localhost 9002 refuses connection.

pdshow DfmBroker shows "Program started - No mgt msgs received"

netstat shows only a tcp connection from port 35647 to 9002 in state "SYN_SENT"

FYI: I just changed the permissons of the c:\windows directory tree - no changes to the CSCOpx directory has been made.

Joe Clarke Thu, 08/23/2007 - 07:32

What version of DFM are you running? How many swap files do you have configured? How many brstart applications are seen in Process Monitor?

t.kraemer Fri, 08/24/2007 - 06:25

I'm running DFM 2.0.7 and see 2 brstart processes in the monitor.

t.kraemer Fri, 08/24/2007 - 06:56

When I run brstart --port=9002 DfmServer registers after a while and DFM starts working. That rights does casuser need to run brstart? In my last posting I told that brstart is running twice as user casuser, but port 9002 does not open.

Joe Clarke Fri, 08/24/2007 - 08:15

Two brstarts should be running typically. Try running NMSROOT\setup\support\resetCasuser.exe and see if that sorts this out.

Joe Clarke Fri, 08/24/2007 - 09:33

Then make sure the perms on C:\WINDOWS are as follows:

local Administrator : Full Control

CREATOR OWNER : Full Control

SYSTEM : Full Control

local Administrators group : Full Control

local Users group : Read & Execute

local Power Users group : Modify

mrguitar Wed, 01/30/2008 - 11:25

Did you ever find a resolution to this issue? If so, can you please let me know what it is? I'm having the same issue.

Joe Clarke Thu, 01/31/2008 - 10:01

Then provided you've done everything else suggested in this thread already, please indicate whether or not this server has .NET 2.0 SP1 or higher installed as well as post the brstart.log.


This Discussion