Upgrading CSACS 3.3 to 4.1

Unanswered Question
Aug 22nd, 2007

We are getting an error saying that the old installation folder appears to be locked. Has anyone else experienced this?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Premdeep Banga Wed, 08/22/2007 - 14:35

I would like to encourage, to use "Search NetPro" on the extreme right. That will answer most of the common issues that you face.

For your issue, try these,

Please remove all the file from following location and then try ( these files are debug files, so we donot require them) :








Please take a backup of following folder, if auditing is required in our organization :


After taking backup of this folder, please remove logs from following location:


\Logs\Backup and Restore


\Logs\Failed Attempts

\Logs\RADIUS Accounting


\Logs\TACACS+ Accounting

\Logs\TACACS+ Administration

- Stop any anitvirus software that might be running.

- Ensure that if you are using CSMARS, and you are using pnlogagent, then that service is stopped, which can be done from services.msc.

- In the end, Also make sure that Drive on which ACS is installed or intallation folder or sub-folders are not shared.



siligato Wed, 08/22/2007 - 14:42

Thanks for your response. We already deleted a boatload of files and have stopped antivirus. We are not using CSMARS.

siligato Wed, 08/22/2007 - 14:45

We had problems when we tested the upgrade on our test box. We wanted to install 4.1 on the D drive and it didn't like it. We were told today by a Cisco tech that it should work on the 'D" drive. We tried on both the D drive and C drive.

Premdeep Banga Wed, 08/22/2007 - 14:48

- On which drive is ACS version 3.3 installed?

- Try to upgrade on the very same drive, as you can change the location later.

- Stop the ACS services manually, and check the folder permissions, and make sure that there is no sharing going on, or some sort of script that might be using it.



siligato Wed, 08/22/2007 - 15:05

3.3 is on the D drive. We tried it on the same drive. Services stopped manually. We don't see any sharing going on.

Premdeep Banga Wed, 08/22/2007 - 15:13

Okay, if you have done everything that I have suggested. Then there is only one last thing left...

Take a backup from the current ACS 3.3 version from

system Configuration > ACS Backup > Backup Now.

Take a test system, Install the same version, restore the database that we took above, from

System Configuration > ACS Restore....

And then upgrade and share the result. If it succeeds, then something is indeed blocking on your server.

other way around, if you have a TAC case opened, provide backup to TAC engineer and let them upgrade and see if they are experiencing the same issue.



siligato Wed, 08/22/2007 - 15:21

Thanks Prem. We did receive an email from our TAC engineer about 15 minutes ago or so, we gave him some information that he requested and we are waiting to hear back from him again.

As far as a test system goes, we did that last month and had issues using the D drive. We finally got 4.1 installed on the C drive.


This Discussion