Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Intel and Cisco LWAPP - Sucess at last

Unanswered Question
Aug 22nd, 2007
User Badges:

I work for a large healthcare system that has a very large LWAPP deployment. We utilize the network for laptops, 7920 IP phones, and the new 7921 phones. We have HP laptops with Intel wireless cards. We have both the HP 6120 and 6320 laptops with the Intel 2915 and 3945 Intel wireless abg clients. There has always been a beacon interoperability problem between these intel clients and lwapp. This has been a huge issue that neither Intel nor Cisco has wanted to deal with.

The problem has finally been resolved with LWAPP code release I upgraded my 4404-100 controllers to to fix some possible arp issues I was seeing on our new Cisco 7921 phones. Not only did it resolve the arp problem, all my Intel problems went away.

It was interesting because I did the upgrade the night before I had HP and Intel engineers onsite to troubleshoot the interoperability issues - we were giving them one more chance to resolve the issue before we were probably going to switch to a different laptop and wireless card that had a proven record for working with LWAPP - like Thinkpad with atheros.

When the engineers arrived, the problem could not be reproduced - constant drops off the network and wild roaming (we have a very dense AP deployment (1232 & 1242 APs).

We recretaed the problem by downgrading a controller to 4.1.171.

I am extermely happy that we finally found a code to support the laptops and is also still compatabile with our 7921 phones. We have about 200 7921 phones we are deploying on 802.11a. We plan on keeping the data on b/g.

I am posting this just in case other people have similar issues.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (3 ratings)
chigevsky Thu, 08/23/2007 - 01:17
User Badges:

Thank you very much for your message, it's very useful. I'm experiencing a random disconnection problem with intel+LWAPP.

Could you please clarify which version of intel wireless cards you are running? Do you have any 2200BG clients?

j.teeter Thu, 08/23/2007 - 06:31
User Badges:

We have been experimenting with multiple intel drivers/clients. They range from 10.5 to 11.1.15 (new engineering Intel version). Nothing solved the lwapp beacon issue - especially on the HP 6120 that has the Inetl 2915 wireless card. By upgrading to the lwapp code, the beacon problem went away.

One way to tell if you are having this issue if you are using the Intel Pro Wireless software is to look at advanced statistics under the advanced tab and look for "poor beacon quality". You will see the poor beacon quality increment. If you have a dense AP environment - this counter will increment very aggresively. After the lwapp code upgrade, we stopped seeing any poor beacon quality counts.

fynskisb16 Thu, 08/23/2007 - 13:44
User Badges:

Is there anyway of telling your having problems using the WZC utility within windows? We have had add issue with clients dropping. We are on code

j.teeter Fri, 08/24/2007 - 01:32
User Badges:

I don't know too much about the windows client/driver. We stayed away from microsoft wireless clients because they didnt use to support the stronger EAP types. I know that the Windows XP now supports WPA2 (finally).

As you probably know, one of the big differences with LWAPP from a traditional Cisco AP is that they have to send out a seperate beacon for each SSID that configured instead of just one beacon per AP. I suppose that is why there is also a limit of 8 SSIDs on the 1232/1242 Cisco LWAPP APs.

You can also see the beacons on Air Magnet and also on RF capture software.

j.teeter Mon, 08/27/2007 - 08:08
User Badges:

Inetl has an issue where for some reason if they don't "hear" the beacon they are wanting, they drop off the network. They are starting to resolve the issue with their new Intel client/driver releases.

Cisco has made some changes in their recent code to help make the problem not as painful. Neither Cisco nor Intel want to disclose a lot of information on the issue.

Thanks J,

We may be experiencing similar issues - also in a healthcare setting with HPs using 2915 and 3945 cards. So its a matter of them not responding to beacons in a timely manner - possibly a power save or DTIM issue perhaps. Did you have to use PROset 11.1.15 to correct the issue as well?

j.teeter Mon, 08/27/2007 - 10:10
User Badges:

If you are on a LWAPP platform (the 4.x train)- would recommend testing the software version. Once you have this running on the lwapp platform, it fixes all the beacon issues.

pmccubbin Mon, 08/27/2007 - 11:38
User Badges:
  • Silver, 250 points or more

We upgraded the WLC to 4.1.185 and we changed the power settings on the Intel card from the default to MAX.

Do a right click on your PC--->Properties---Hardware--->Device Manager--->Intel Wireless--->Properties--->Power Management.

Here is the straight talk from the Intel site:

If the wireless access point (AP) or broadband wireless router does not properly support the PSP feature, intermittent loss of wireless connection, inability to initiate a wireless connection, or poor wireless connection data performance could result. The symptoms may be more pronounced when on battery power.


In a mobile environment, power save polling mode is a feature for extended battery life for mobile stations. The capability requires coordination between the AP/router and the laptop's wireless adapter for proper operations. Intel has discovered the feature may not be implemented correctly or completely in some wireless access points or wireless gateway devices.


Contact the AP/router vendor for updated software or firmware that corrects the problem.

As a temporary workaround, manually set the wireless adapter to CAM (continually aware mode), which disables the PSP capability. To do this, in either Intel? PROSet/Wireless Software or the Network Control Panel Applet (NCPA), in the power management section, uncheck the DEFAULT / AUTO selection and set the slider for HIGHEST / MAXIMUM PERFORMANCE.


To ensure the adapter is set to CAM - if the slider is already at the HIGHEST / MAXIMUM PERFORMANCE setting, move the slider to another setting and then back to HIGHEST / MAXIMUM PERFORMANCE.

Hope this helps.

j.teeter Mon, 08/27/2007 - 11:48
User Badges:

In our situation, our laptops were all configured to constantly be awake (CAM). It wasn't until we went to the that our issues were solved with the Intel 2915 wireless card. The Intel 3945 card wasnt having as many issues, but the 2915 had really bad performance until we upgraded the lwapp code.

j.teeter Sat, 08/25/2007 - 11:57
User Badges:

We have a mixture - we have a couple hundred 1232 that have SSC, the rest are MICs. All of the 1242 our MICs


This Discussion



Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode