Catalyst 3560 - "snmp trap link-status"

Unanswered Question
Aug 23rd, 2007
User Badges:

Hi Sir,


I'm configuring a Catalyst 3560 to send SNMP linkdown and linkup traps that applies to only a small number of ports.


The global config command is "snmp-server enable traps snmp linkdown linkup". I understand that by default, SNMP link traps are sent when an interface goes up or down via the command "snmp trap link-status".


For my case, I'll disable the trap on all ports (doing a "no snmp trap link-status") and then enable it only on those few ports that require it. Is the other way to accomplish the task?


Please advise.



Thank you.


B.Rgds,

Lim TS


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
purohit_810 Thu, 08/23/2007 - 04:34
User Badges:
  • Silver, 250 points or more

Hi,


As of my understand you would eliminate unnecessary traps comes from the router. Which are really not important. Because of in too many LOGs people are sometimes missing Important LOGs. So you would monitor perticular interface Link !!!!



Okie.


If you would monitor particular interface link :


Command:

Router(config)# snmp-server trap-source ethernet 2/1


If you would monitor ROUTER..with only one interface than .. create one loopback

interface and monitor that.



Regards,

Dharmesh Purohit



steve.busby Thu, 08/23/2007 - 09:03
User Badges:
  • Silver, 250 points or more

From this link:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121newft/121t/121t3/dtitraps.htm


"The snmp-server enable traps snmp [linkup] [linkdown] form of this command globally enables or disables SNMP linkUp and linkDown traps. After enabling either of these traps globally, you can disable them on specific interfaces using the no snmp trap link-status command in interface configuration mode. On the interface level, linkUp and linkDown traps are enabled by default, which means that these notifications do not have to be enabled on a per-interface basis. However, linkUp and linkDown notifications will not be sent unless you enable them globally using the snmp-server enable traps snmp command."


HTH

Steve

limtohsoon Wed, 10/10/2007 - 22:03
User Badges:

Hi Steve,


Thanks for your reply.


Is this behavior also valid on routers?


I did "debug snmp packets" on a router. I did see the following console messages:


SNMP: Queuing packet to

SNMP: V1 Trap ...


when an interface goes up/down.


Kindly confirm.



Thank you.


B.Rgds,

Lim TS


David Stanford Thu, 08/23/2007 - 09:25
User Badges:
  • Cisco Employee,

This is a fine way of doing it if you only want to send it from a few ports, but using this command on the interface level.


Can't think of another way to do it

Actions

This Discussion