RME image location directory

Answered Question
Aug 23rd, 2007

Hello

We have RME version 4.0.5. Everything installed on Solaris (SunOS 5.8 Generic_117350-46 sun4u sparc SUNW,Sun-Fire-280R).

I've created directory:

/worksy_images which belongs to: casuser:casusers

Apache serving cisco works is working under casuser:casusers. But when i wanted to configure RME, and in ViewEditPreferences/Image Location typed: /worksy_images i received error:

"User Error: Invalid data directory. Recommended action: Verify that directory exists"

Why ? Directory exists.

Thanx

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 9 years 3 months ago

I wonder if perhaps there is a disconnect between the UI and the backend. Shutdown dmgtd, and go to /opt/CSCOpx/MDC/tomcat/work/Standalone/localhost and remove everything in that directory. Then restart dmgtd, and try to adjust the image location.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
Joe Clarke Thu, 08/23/2007 - 22:57

This should work just fine. Is /worksy_images a mount point? If so, unmount the file system, then look at the permissions on /worksy_images. They should be 0755.

mlopacinski Thu, 08/23/2007 - 23:23

It was mount point but i also tried other directories. For example:

/var/adm/CSCOpx/files/scripts/swim/images

it belogns to casauser:casusers and has 0755 privs. But still the same problem.

To be more specific, when i want to apply i receive two exactly same errors in one window:

"User Error: Invalid data directory. Recommended action: Verify that directory exists"

in/var/adm/CSCOpx/log/swim_debug.log i found some info:

[ Fri Aug 24 09:07:50 MEST 2007 ],INFO ,[Ajp13Processor[9009][9]],com.cisco.nm.rmeng.swim.administration.AdminPreferences,setImagesDirectory,730,Into setImagesDirectory

[ Fri Aug 24 09:07:50 MEST 2007 ],INFO ,[Ajp13Processor[9009][9]],com.cisco.nm.rmeng.repository.RepositoryAdminSvc,getRepository,?,Entered geRepository(). Get the repository object for null

[ Fri Aug 24 09:07:50 MEST 2007 ],ERROR,[Ajp13Processor[9009][9]],com.cisco.nm.rmeng.repository.common.FileManager,,?,User Error: Invalid data directory. Recommended Action: Verify that the directory exists.

[ Fri Aug 24 09:07:50 MEST 2007 ],ERROR,[Ajp13Processor[9009][9]],com.cisco.nm.rmeng.repository.RepositoryAdminSvc,getRepository,?,Caught Repository Exception. Error Message = com.cisco.nm.rmeng.repository.common.RepositoryException

What's wrong ?

Correct Answer
Joe Clarke Fri, 08/24/2007 - 08:04

I wonder if perhaps there is a disconnect between the UI and the backend. Shutdown dmgtd, and go to /opt/CSCOpx/MDC/tomcat/work/Standalone/localhost and remove everything in that directory. Then restart dmgtd, and try to adjust the image location.

mlopacinski Sun, 08/26/2007 - 21:59

Hello

I solved this problem:

i need to have directory:

/var/adm/CSCOpx/files/rme/repository

this is the only one which could "be found".

It's working fine right now:)

Actions

This Discussion