FRTS on Interfaces vs. Class Based

Unanswered Question
Aug 24th, 2007
User Badges:

Is there an advantage to one or the other? I know that you can view the whole policy easier using show policy-map int <interface>, but other than that, is there a fundamental difference from how the FRTS is being applied?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Edison Ortiz Fri, 08/24/2007 - 06:55
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

I believe you are comparing GTS (Generic Traffic Shaping) vs FRTS (Frame-Relay Traffic Shaping). GTS can be applied on any kind of interface; ethernet, serial, atm, etc. FRTS can only be applied on interfaces running frame-relay. FRTS is more granular QoS for frame-relay since it allows you to apply policies per PVC while GTS treats the interface as one PVC. If you have multiple PVCs on a serial interface, GTS will apply the same QoS in all of them.


Joseph W. Doherty Fri, 08/24/2007 - 09:15
User Badges:
  • Super Bronze, 10000 points or more

If by class based you mean CBWFQ, then it's primary advantage is treating different traffic differently. Shapers throttle traffic to a rate specified by you with often little control over how the delayed traffic is queued. Is such traffic queued FIFO, or FQ, or WFQ? Is only tail drops implemented or can you do RED, or WRED. Can any traffic be prioritized to jump before all the other traffic? These are many of the features you often can select with CBWFQ that are unlikely to be available with FRTS, or other single function shapers. Oh, and CBWFQ often supports shaping and/or rate limiting too.


E.g., from a 7500:


policy-map shapeAvg1500cir256

class class-default

shape average 1450000 11600 11600

shape adaptive 256000

shape fecn-adapt

queue-limit 256

fair-queue


interface Serial6/0/3

bandwidth xxxx

no ip address

ip access-group 199 in

ip flow egress

encapsulation frame-relay

no ip mroute-cache

load-interval 30

serial restart-delay 0

no fair-queue

frame-relay lmi-type cisco

frame-relay broadcast-queue 128 8000 64

!

interface Serial6/0/3.100 point-to-point

ip address x.x.x.x

ip access-group 111 in

ip flow egress

no arp frame-relay

frame-relay interface-dlci 100

service-policy output shapeAvg1500cir256

!

interface Serial6/0/3.400 point-to-point

ip address x.x.x.x

ip access-group 111 in

ip flow egress

no arp frame-relay

frame-relay interface-dlci 400

service-policy output shapeAvg1500cir256

sundar.palaniappan Fri, 08/24/2007 - 10:09
User Badges:
  • Green, 3000 points or more

Cisco is moving in the direction of MQC aka., Modular QOS configuration. MQC gives you the flexibility to accommodate multiple QOS attributes to the same traffic class in a policy map. With that said MQC based shaping can achieve most of what FRTS shaping can do. If the criteria can be met with both FRTS and MQC based shaping then you may choose the option that you are more comfortable with.


HTH


Sundar

Mohamed Sobair Sat, 08/25/2007 - 00:22
User Badges:
  • Gold, 750 points or more

Hi,


I have one comment to add, In FRTS you are applying your bandwidth parameters according to prevent SP dropp your traffic which could be very sensitive like Video/Audio streaming.


The Adaptive shaping command enables you router to respond to BECN messages thus slowing down the connection if its exceeds the limits when the BECN flag set at the framerelay header, this eleminate SP dropps your important traffic if any. Moreover , FRTS could be applied on per DLCI basis.


With Policing , you can match based on NBAR which is amazing feature, thus you can figure which applications consumes how much traffic by issuing (sh ip nbar protocol-discovery) command.


Difference, both usually is used differently, FRTS is used within FR cloud, and Policing is used for any other application/protocols ..etc


Regards,

Mohamed Sobair

Actions

This Discussion