Catalyst 2950 Help

Unanswered Question
Aug 27th, 2007

Hello Everyone,

We recently picked up a new Catalyst switch. I ran the Express Setup, and gave it the correct IP configuration. We rack mounted the switch and connected the ethernet cables to it.

When I plugged my laptop into the switch, I did not receive an IP address from my DHCP server on the same subnet. I manually assigned my laptop an IP and I was able to communicate with the switch.

However, I could not ping any other internal servers or the default gateway. Any ideas why this thing is not talking to the other machines on it's network?

Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

By default all ports are on default vlan (vlan id 1) so your laptop was on vlan 1. When you connected the switch to the network it must have negotiated the uplink port as a trunk. If the rest of the hosts on that subnet were in vlan X (other than 1) on the other swithces then this might be the problem.

This is only one scenario i can think of. Maybe it helps.

Primitive Mon, 08/27/2007 - 10:09

We aren't using VLANs on the other switches. At one point, I disconnected the other switches and plugged the firewall right into the catalyst. I still couldn't ping the firewall.

Thoughts?

dhavaltandel Mon, 08/27/2007 - 10:49

Hi

can you tell me what design you have.?

how you have install your catalyst in to your existing network.?

Dhaval

Primitive Mon, 08/27/2007 - 11:16

The Catalyst is connected to a 3com via SX Fiber. Most of the patch cables are connected to the Catalyst, but some were connected to the 3com.

fred.mancen Mon, 08/27/2007 - 11:16

Hi.

At first, re-check all your IP settings on the switch, as the IP Address and the default gateway. If you already had defined the IP manually on the switch and it is still not working, probably you have a problem at the network stack, once your notebook works when connected to one port on the switch.

Regards,

Fred.

fred.mancen Mon, 08/27/2007 - 12:40

Since you have a new switch on the LAN that is not responding to ping, and assuming that the DHCP server is working fine(you got an IP when using the notebook, right?), there is not a firewall blocking any kind of requests, there is no other VLANs than the default and you can ping other devices using the notebook, the only thing that I can see that could be wrong is the switch management IP address settings. Once you entered the config:

switch(config)# interface vlan 1

switch(config-if)#ip address x.x.x.x y.y.y.y

switch(config-if)#no shut

switch(config-if)#exit

switch(config)#ip default gateway

The switch have to work...it is weird.

Primitive Mon, 08/27/2007 - 13:53

Yes, you are forced to create on VLAN upon setting the switch up.

Actions

This Discussion