How to downgrade DSP firware

Unanswered Question

We are ruuning IOS 12.4.6 at Router3845 which has a built-in DSP 7.4.1. We got a lot of voice quality complains from Customer. It looks like We are hitting Cisco Bug CSCsd54344. What i am trying to do is get a DSP firware 4.4.18 or 7.4.1 from another 3845 and change the DSP.

My question is:

1. Which dsp is better 4.4.18 or 7.4.1?

2. How to get the DSP firmware from another 3845 and how do I upgrade the DSP? Is it sitting on the flash?


Thanks for any input.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mchandak Mon, 08/27/2007 - 16:03
User Badges:
  • Gold, 750 points or more

DSP firmware is inbuilt into the IOS. The best option here would be to upgrade the IOS to the latest T Train as that would have a fix for the problem

tnooning Wed, 08/29/2007 - 05:31
User Badges:

If you can get a standalone version of the DSPware, load it to flash and reboot. If it sees it in flash, it will load it instead of the default. I had to send TAC a 'show diag' to get the correct file. But since it requires a reload anyway, why not just upgrade the IOS?

mchandak Wed, 08/29/2007 - 05:33
User Badges:
  • Gold, 750 points or more

Yes, reload is needed and IOS upgrade could be the best solution. But at times, you cannot upgrade the IOS, if the H/W (Example, Flash and RAM) is not supported with the IOS which has a fix.

Actions

This Discussion