H323 outbound calls fails

Unanswered Question
Aug 28th, 2007

Hello

I am using CM 4.1 and a VG-200 with a 2FXO-M1 and a 2FXS

I have H323 configured on the 2FXO-M1 so I can use the caller-Id feature.

The CM has a route pattern of 9.@ for out bound calls. Under MGCP control, all outbound and inbound calls works ok. when I point it to the the H323 controled port, it will not dial out.

I can receive calls on the H323 port and it is routed to the phones.

I have looked all over the forums and I have tried many examples but none are working. I am sure that I must be missing 1 small thing somewhere. Any help please. A actual config example would be nice as well.

Here is how the the VG-200 is configured. It has a mix of MGCP and H323 while I was experimenting.

voice-port 1/1/0

description FXO Gateway to PSTN Port 0

caller-id enable

!

voice-port 1/1/1

description FXO Gateway to PSTN Port 1

connection plar opx 4110

ring number 1

dial-peer voice 110 pots

description FXO Gateway to PSTN Port 0

tone ringback alert-no-PI

application mgcpapp

port 1/1/0

!

dial-peer voice 120 pots

description FXO Gateway to PSTN Port 1

tone ringback alert-no-PI

destination-pattern 9....

prefix 9

port 1/1/1

!

dial-peer voice 4110 voip

description - VOIP calls to call manager

tone ringback alert-no-PI

preference 1

application mgcpapp

session target ipv4:192.168.10.48

!

!

dial-peer voice 4112 voip

description - VOIP calls to call manager

preference 1

destination-pattern 4110

session target ipv4:192.168.10.48

dtmf-relay h245-alphanumeric

codec g711ulaw

!

gateway

emulate cisco h323 bandwidth

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
jdcutcher Wed, 08/29/2007 - 03:56

A TAC engineer once told me you cannot mix H323 and MGCP on the same device.

Maybe that's true, maybe it's not, but I would start there. Get rid of mgcp dial-peers. Remove MGCP commands on interfaces and ports, and any other MGCP commands you have on the device.

If that still doesn't work, I would suspect it's a problem with call type/plan. I'd run a debug on the call.

You said it won't dial out... you don't get any kind of error message at all? Are you sure the call is getting to the gateway?

nexus1467 Wed, 08/29/2007 - 05:59

Yes as soon as you dial out, it replies with "Your call can not be completed as dialed" unless it is under mgcp control and witch case it will place a call.

I did do a "no mgcp" to shut down the mgcp services but it did not help.

jbarcena Wed, 08/29/2007 - 06:19

"Your call can not be completed as dialed" is the CCM annuntiator, which means that the call is not reaching the GW. I recommend you to take a CCM detailed trace to see what is going on. Check the CSS of the phone and make sure that it can reach the Route Pattern that has control over the GW.

//Jorge

nexus1467 Wed, 08/29/2007 - 06:36

I added a CSS and all get is a busy signal when dialing out

mchandak Wed, 08/29/2007 - 06:41

Under "dial-peer voice 120 pots", you have prefix of 9, does your Telco need a 9 ?? Normally Telco's dont need the 9 to be prefixed. Can you remove that and then give it a try. Also, do you have any discard digits configured on the CM, if yes, remove that as well, since the Router is expecting a 9 as well.

Hope this helps

nexus1467 Wed, 08/29/2007 - 07:04

That worked.

Adding the CSS, changing the discard digits to "none", and removing the prefix 9 solved it.

I added the "prefix 9" as one of my attempts to get it working.

Thanks all for you help!

Actions

This Discussion