Avaya IP phone not picking IP from Voice VLAN

Unanswered Question
Aug 29th, 2007

we have Avaya IP phones model 4610. They are connected to Cisco 6513 switches. We have following configs on each 6513 switch to support Avaya IP phones.

interface FastEthernet1/23


switchport access vlan 60

switchport mode access

switchport voice vlan 130

no ip address

mls qos trust cos

spanning-tree portfast

We have configured option 176 for every scope(except scope for VLAN 130 which is Voice VLAN) in Microsoft DHCP server with following parameters


where L2QVLAN = 130 is the dedicated vlan for IP phones i.e vlan 130.

Issue is that on every boot IP phones could only pick IP from access vlan 60 but not from voice vlan 130. Please suggest if we have to do any extra config in our switching environment in order to make Avaya IP phones pick IP from VLAN 130. We want to connect the Workstations Via IP phones and we do not want to Dot1q trunking on every switch port.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
msrohman Wed, 08/29/2007 - 16:07

Do you have CDP v2 running on the switch?

'show cdp neighbor detail' will list whether the CDP nodes are advertising v2. We had the same problem with some Mitel IP phones, but then we checked the CDP version. CDP v1 does not advertise Voice VLAN information for the IP phone.



rebecca.richards Wed, 08/29/2007 - 18:55


On our network, we have the following configuration on the switch ports:

interface Fa0/3

switchport mode access

switchport access vlan 100

switchport nonegotiate

switchport voice vlan 150

auto qos voip trust

no cdp enable

spanning-tree portfast

VLAN 100 is the data VLAN, and VLAN 150 is the voice VLAN.

In the DHCP scope serving the DATA VLAN, there is:

Option 176: L2Q=1,L2QVLAN=150,VLANTEST=0

... and in the DHCP scope for the VOICE VLAN, there is:

Option 176: MCIPADD=x.x.x.x,MCPORT=1719,TFTPSRVR=y.y.y.y,VLANTEST=0

We do DHCP for the voice VLAN on the router, and DHCP on the Data VLAN on the local server.

The Avaya phone initially picks up a data VLAN IP address, sees the option 176, reconfigures the VLAN to 150, and then redoes the DHCP request.


- bec

bmarms Fri, 10/05/2007 - 08:54

what do your vlan interface configs look like? are you using ip-helper to relay info to your dhcp server? do you have that configured on your voice vlan interface?

hassan_oudeh Sun, 10/07/2007 - 14:32

i have this dhcp pool configured for both data and voic on 3560 switch:

ip dhcp pool DATA

. network

. default-router

ip dhcp pool Voice

. network

. default-router

Interface gig0/1

. Description connect to AVAYA IP Telephone

. Switchport mode trunk

. Switchport trunk encapsulation dot1q

. Switchport trunk native VLAN 1

. Switchport voice VLAN 5

. Spanning-tree portfast

. No cdp enable

. Auto qos voip trust

when i give the AVAYA IP Phone with static IP address it's working fine. but using dhcp is able to get any IP address ?????

please advice



rebecca.richards Sun, 10/07/2007 - 19:55


See my original reply above for info on how I'm configuring Avaya phones and Cisco switches and routers. Your switch interface config is different to mine (trunk v access) - we originally started with trunk mode on the ports, but switched over to access mode due to various issues (which I now can't recall...).

I do the DHCP on the router, not on the switches. DHCP for the voice VLAN is on the router, and DHCP for the data VLAN is on the local file server.

The Avaya phones will initially connect to the network using the Data VLAN (in your case VLAN 1). As you have no other information in your DHCP scope, the Avaya phone will not know which VLAN to switch to from there, so it will likely stay on the data VLAN. Dunno whether that's your problem.

You can hard-code the VLAN into the Avaya phones, so they boot into VLAN 5 straight away.

As a first step, put the DHCP scope for the voice VLAN on the router, and make sure the router has an interface on that VLAN (SVI or otherwise), and add the additional DHCP options (as I have them above) to the scopes (both the data and voice VLAN scopes), and re-test.

- bec


This Discussion