PIX 6.3 NAT - Global problem.

Unanswered Question
Aug 29th, 2007
User Badges:

Hi


I'm experiencing a strange problem with NATing on a PIX 515 running 6.3. I have 2 statements:


nat (inside) 1 10.0.0.0 255.0.0.0

global (DMZ2) 1 192.168.194.0 netmask 255.255.254.0



With this config I can get no packets at all to pass from the inside and out of the DMZ2 interface (using debug any any on both interfaces). Yet when I change the global to a /8 mask (i.e 192.0.0.0) packets pass through fine. I've noticed on the debug trace that the source port is altered even where the subnets are of equal size on the nat and global (i.e where both subnets are /8 Port address translation is occurring) so I'm at a loss why the larger (/8) pool cannot be translated sucessfully to the smaller (/23) pool.

Does anyone know of a bug in the software or am I missing some config?

Regards

Paul

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
PDEdwards Wed, 08/29/2007 - 04:59
User Badges:

Hi


I should add that the DMZ2 interface is part of a vlan - if that's relevant!


Regards

Paul

mattiaseriksson Wed, 08/29/2007 - 05:11
User Badges:
  • Bronze, 100 points or more

If you want to use dynamic NAT and not PAT you can try to define the pool like this:


global (DMZ2) 1 192.168.194.1-192.168.195.254 netmask 255.255.254.0


Dont forget clear xlate

mattiaseriksson Wed, 08/29/2007 - 05:29
User Badges:
  • Bronze, 100 points or more

What do you see in the log?


Debug xlate can help as well.

Actions

This Discussion