Pruning vlan

Unanswered Question

Can anyone explain what exactly do i achieve with the pruning configuration listed below when there are only specific vlans allowed on the trunk?

interface FastEthernet5/28

switchport access vlan 102

switchport trunk encapsulation dot1q

switchport trunk native vlan 102

switchport trunk allowed vlan 102,120

switchport trunk pruning vlan 2-101,103-119,121-1000

switchport mode trunk

switchport voice vlan 120

speed 100

duplex full

qos trust dscp


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Jon Marshall Wed, 08/29/2007 - 05:10


As far as i can see you don't achieve anything. Pruning is useful to sutomatically stop vlan traffic being propogated down links when that vlan is not in use at the far end of the link but as you have specifically only allowed vlan 102 and 120 traffic then i would say the pruning is unnecessary.


royalblues Wed, 08/29/2007 - 05:38

It would help when you have pruning enabled but you do not configure the switchport trunk allowed vlan command under the interface


nambi_gct Wed, 08/29/2007 - 05:38

Hi,What if a switch and its downstream switches dont have any access ports for vlan 100(for example).in this case pruning avoids unnecessary traffic for vlan100 over the trunks.

royalblues Wed, 08/29/2007 - 05:40

You are right but when we allowe only specific vlans over the trunk using the switchport trunk allowed vlan command, pruning would be unnecessary.

Even if do not prune for eg vlan 200, it will not be allowed over thetrunks due to the above command




This Discussion