FXS/DID caller id support with H.323 gw

Unanswered Question
Aug 29th, 2007

I noticed a post questioning if it was possible to recieve caller id on a FXS/DID port in DID mode...I have this implemented and do not see caller id..is this a limitation of the card or is it possible?

Thanks,

Joe

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
thomas.chen Tue, 09/04/2007 - 11:33

Enable the caller-ID, H.323 gw will support.

The [no] caller-id enable command enables or disables the transmission of Caller ID on an FXS port, and enables or disables reception of Caller ID on an FXO port.

Issue the [no] caller-id enable command to enable the Caller ID name for inbound PSTN calls on the FXO port.

You must configure the alerting method when the Caller ID standard, specified by locale through the cptone command, is not Bellcore/Telcordia. If you do not configure the alerting method, the default caller-id alerting ring 1 command is applied. The command that you enter is determined by the Bellcore/Telcordia or ETSI standard that your service provider uses for Caller ID.

joeharb Tue, 09/04/2007 - 12:22

Thomas,

Thanks for your reply...I have no issues with the caller-id command on a FXO or FXS card...but when you use the FXS in DID mode the command is not available. I assume this is a limitation of the card. Please let me know your thoughts...

Joe

Joe,

I'm attempting the same implementation- I've run into this once before where the carrier states they do not pass caller-id on analog DIDs. (This was SNET/SBC last year; and now a telco in Northern Pittsburgh). I, too, can not enable/disable caller-id on the sub interface. I'm assuming everything is OK on my end and it is the fact, as stated by telco, that they do not pass the info.

Paolo Bevilacqua Mon, 10/08/2007 - 10:30

I believe that analog DID trunks never support caller-id. If you want DID and CLID and all the fancies, get ISDN BRI.

Actions

This Discussion