Agents goes into reserved state when they enable ready

Unanswered Question
Aug 30th, 2007

we are running IPCC enterprise with ICM 7.0 and ccm 4.1(3) sr2 when some of the agents goes into ready state then automatically there status goes into reserved then after 5 to 10 sec there state becomes ready and call lands on the CTIOS ,please update me if any body have a clue

i would be thankfull

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Zin.Karzazi Thu, 08/30/2007 - 04:10

Check that the Label Configuration (ICM Congiguration->Device Target) is right for every client (CCM, IVRS).

Try to deassociate the device of an Agent from your JTAPI user defined on CCM, delete the user in CCM, add him back, then associate the device to JTAPI, see if that work.

If not, recycle your PGs.

Hope this helps.

haroon.rasheed Thu, 08/30/2007 - 05:43

yes we have tried the device targets but wht about this jtapi user can u please clarify wht does it mean, the association we do is with the pg's and if we do change it then wht effect will it make, about recycling the pg's we did it and we cycled the call manager as well.

Zin.Karzazi Fri, 08/31/2007 - 03:14

The Jtapi user is a user you ve configured on the Callmanager while installing IPCC. The user should have control of every device, which will use IPCC (CTIOS). Go to CCM admin Page->User->Global Directory and search for it, then click device association and do what i said on the first post :).


ZInedine Karazi

haroon.rasheed Wed, 09/05/2007 - 05:53

Thanks for the reply but unfortunately i have tried it but it didnt work, please update me with some other resolution.

david.macias Wed, 09/05/2007 - 05:55

I agree, it has to be a jtapi/pguser issue. Have you tried that same agent on a different device?


haroon.rasheed Thu, 09/06/2007 - 06:16

Yes i agree with you guys that it could be the issue but we have got 2 remote locations where our agents are taking calls using the same jtapi users, on one side we havent faced any issue but on the other side there are some complains regarding it, this thing prompts me that there could be some thing else bothering these agents

Zin.Karzazi Thu, 09/06/2007 - 06:37

OK, get us some Logs from your PGs PIM (CCM PIM)and the Jtapigw while the user is experiencing the problem you described, use the dumplog utility for that.


This Discussion