VRF Information

Unanswered Question
Aug 30th, 2007

Hi - Am looking for technical information related to deploying and configuring VRFs in a network. Also, basic info on VRF tables,L3 associations., etc.

Thanks,

KC

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mohammedmahmoud Thu, 08/30/2007 - 12:51

Hi,

If you are asking about VRF Lite, then VRF lite converts the router into multiple virtual routers each one with its separated routing table (called VRF table), interfaces and routing protocols.

http://www.cisco.com/en/US/products/hw/switches/ps4324/products_configuration_guide_chapter09186a00801cddd9.html

Router(config)# ip vrf customer

Router(config-vrf)# rd 1:1

Router(config-vrf)# route-target both 1:1

Router(config)# interface fastEthernet 0.1

Router(config-subif)# ip vrf forwarding customer

Note VRF-Lite does not include the Provider Edge MPLS functionality. More specifically, MPLS label switching and MPLS control plane are not supported in the VRF-Lite implementation, if you are looking about this please let me know.

HTH,

Mohammed Mahmoud.

kcgeorge1218 Fri, 08/31/2007 - 07:58

Thx,MM. Good info. Here's the setup..have a 6509-E and a 4948-G switch. Trying to build VRF instances between the two.

4948-G:

ip vrf vrf-100

rd 65001:100

route-target export 65001:100

route-target import 65000:100

6509-E:

ip vrf vrf-max

rd 65000:100

route-target export 65000:100

route-target import 65001:100

Associated vrf-100 to VLAN100 & VLAN10 on the 4948. There's E-BGP between the 6509-E(AS65000)and the 4948-G(AS65001).

Created an address-family on the 4948(ipv4 vrf vrf-100)with e-bgp neighbor to 6509, included networks for VLAN10 and VLAN100. Same on the 6509(address-family ipv4 vrf vrf-max) with e-bgp to the 4948 switch.

here's the problem, when I do a show ip route vrf vrf-100 on the 4948-G switch, it doesn't list the routes on the 6509 switch. Pls advise if something's missing..

KC

mohammedmahmoud Fri, 08/31/2007 - 10:17

Hi,

Can you please paste your full BGP configuration from both sides, it should be something like this:

router bgp

address-family ipv4 vrf

neighbor remote-as

network mask

HTH,

Mohammed Mahmoud.

kcgeorge1218 Fri, 08/31/2007 - 10:23

6509E---

router bgp 65000

no synchronization

bgp log-neighbor-changes

neighbor 192.168.110.190 remote-as 65001

no auto-summary

!

address-family ipv4 vrf vrf-max

neighbor 192.168.110.190 remote-as 65001

neighbor 192.168.110.190 activate

no auto-summary

no synchronization

network 192.168.119.224 mask 255.255.255.248

exit-address-family

4948G---

router bgp 65001

no synchronization

bgp router-id 204.155.112.47

bgp log-neighbor-changes

neighbor 192.168.110.189 remote-as 65000

no auto-summary

!

address-family ipv4 vrf vrf-100

neighbor 192.168.110.189 remote-as 65000

neighbor 192.168.110.189 activate

no auto-summary

no synchronization

network 10.193.10.0 mask 255.255.255.0

network 10.193.100.0 mask 255.255.255.0

exit-address-family

mohammedmahmoud Fri, 08/31/2007 - 10:45

Hi,

The configuration is fine, can you please post the relative show ip bgp summary, show ip bgp, and show ip route vrf <>.

HTH,

Mohammed Mahmoud.

mohammedmahmoud Fri, 08/31/2007 - 12:22

Hi,

No i meant the following:

show ip bgp vpnv4 vrf <> summary

show ip bgp vpnv4 vrf <>

HTH,

Mohammed Mahmoud.

kcgeorge1218 Tue, 09/04/2007 - 12:56

6509#sh ip bgp vpnv4 vrf vrf-max summary

BGP router identifier 204.155.112.43, local AS number 65000

BGP table version is 4, main routing table version 4

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

192.168.110.190 4 65001 0 0 0 0 0 never Idle

4948-G#sh ip bgp vpnv4 vrf vrf-100 summary

BGP router identifier 204.155.112.47, local AS number 65001

BGP table version is 9, main routing table version 9

2 network entries using 274 bytes of memory

2 path entries using 136 bytes of memory

2/1 BGP path/bestpath attribute entries using 216 bytes of memory

1 BGP extended community entries using 40 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 666 total bytes of memory

BGP activity 8/6 prefixes, 9/7 paths, scan interval 15 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

192.168.110.189 4 65000 0 0 0 0 0 never Idle

mohammedmahmoud Tue, 09/04/2007 - 13:02

Hi,

Now its obvious, BGP is idle, please make sure that you can ping the opposite interfaces within the respective VRFs, and if you are peering with loopback please make sure that you have appropriate routes and that you can ping your peer ip.

HTH,

Mohammed Mahmoud.

kcgeorge1218 Tue, 09/04/2007 - 13:24

Thx, MM. Will give it a try...the idle state missed me. Was going with the global neighbor established state but overlooked the BGP state via the VRFs.

Actions

This Discussion