Is there any cisco device/firewall which support two ISP

Unanswered Question
Aug 31st, 2007
User Badges:

I have two ISP with respective public IP which are used natting server.Our main purpose is Load balancing and redundancy between two ISP link.If one ISP link is fail access from outside will be live.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mohammedmahmoud Fri, 08/31/2007 - 01:15
User Badges:
  • Green, 3000 points or more

Hi,


You can use a Cisco router with NAT for the load balancing, it should look something like this:



!

interface FastEthernet0/0

ip address

ip nat inside

!

interface Serial0/0

description ***ISP1***

ip address

ip nat outside

!

interface Serial0/1

description ***ISP2**

ip address

ip nat outside

!


!

ip nat inside source route-map ISP1_NAT ...

ip nat inside source route-map ISP2_NAT ...

!

access-list 1 permit

!

route-map ISP1_NAT permit 10

match ip address 1

match interface Serial0/0

!

route-map ISP2_NAT permit 10

match ip address 1

match interface Serial0/1

!


ip route 0.0.0.0 0.0.0.0 serial0/0

ip route 0.0.0.0 0.0.0.0 serial0/1


HTH,

Mohammed Mahmoud.

arjunsawant Fri, 08/31/2007 - 01:43
User Badges:

hi,


Thanks a lot for ur reply,but is it supported to redundancy purpose?


For accessing server from outside,they are natted on firewall.our router's fastethernet ip is public ip which is connected to the firewall.please tell me any scenario if u have.

mohammedmahmoud Fri, 08/31/2007 - 01:57
User Badges:
  • Green, 3000 points or more

Hi,


Yes this establishes load-sharing / redundancy.


HTH,

Mohammed Mahmoud.

mohammedmahmoud Fri, 08/31/2007 - 03:01
User Badges:
  • Green, 3000 points or more

Hi,


Sorry my reply was before you edited your post and added this part "For accessing server from outside,they are natted on firewall.our router's fastethernet ip is public ip which is connected to the firewall.please tell me any scenario if u have".


Cay you please elaborate more on your topology.


BR,

Mohammed Mahmoud.

arjunsawant Fri, 08/31/2007 - 22:21
User Badges:

Hi,


My main purpose is redundancy and load shairing between two ISP.If i take public ip from ISP1 and my ISP1 link fail,i can access internet via ISP2 but external user cant access internal server which are natted on firewall with ISP1 public IP.I cant configure one private ip with two public IP on my current firewall.so is there any device?please help me.Please see attachment.

Is it possible with BGP?is it supported redundancy and load shairing between two ISP?

if possible please send me config example.



Actions

This Discussion