Ip phone stuck in configuring IP

Answered Question
Aug 31st, 2007

Hello

Have a question, My customer just plugged a phone to the Network and Its stuck in "configuring ip" we have auto-registration enabled, we have enough DNs available for this purpose, we issued a factory reset to the phone and we are still not able to register the phone correctly, it is a 7940 and we are running CCM 4.1(3) sr4d

I have this problem too.
0 votes
Correct Answer by lloyd_andrew about 9 years 1 month ago

Cris, did you ever get this resolved?? I have come across the same issue for a customer.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
arcaidy76 Fri, 08/31/2007 - 13:26

Is DHCP configured with option 150 pointing to the TFTP server?

Do you have a voice (aux) vlan configured on the switch port the phone is connected to? If so, try connecting it to a switch port with the only one vlan configured that has access to the dhcp scope with the option 150 configured.

Some of the old 7940/7960 firmware had an issue with connecting correctly to switches that had an aux VLAN configured.

azfarlashari Sun, 09/02/2007 - 23:38

Dear, Simply add manul entry in DHCP with MAC Address of the phone and IP. you will then have to reset the phone. Hope that will work! otherwise please let me know do you have any vlans configured. If yes then please use 'Switchport voice vlan #' on that IP phone port. Please update the status after all

cris_jimenez Tue, 09/04/2007 - 07:57

I pretty much check everything, and I still have the same problem, I would like to try to add a manual entry to the DHCP, our DHCP pool is located on the GW, I was trying to hardcore it but I couldn't could you please let me know the commands that I need to issue

thank you

azfarlashari Tue, 09/04/2007 - 22:57

I wouldnt suggest you to play with router. You can easily configure DHCP on CCM for only 1 or few Phones. That will be easy and quick. Use this link to configure DHCP

http://www.windowsnetworking.com/articles_tutorials/w2kdhcpc.html - Then please also select 150 TFTP Server from 2nd last step. Finaly add a reservation in DHCP, after that add a phone in CCM manually. That should work.

Correct Answer
lloyd_andrew Thu, 10/25/2007 - 11:17

Cris, did you ever get this resolved?? I have come across the same issue for a customer.

cris_jimenez Thu, 10/25/2007 - 13:14

I had to reconfigure the switch port.

re-add it to the voice vlan, that solved the issue

azfarlashari Thu, 10/25/2007 - 20:37

Configure DNCP, Add scope of one or two IPs, Conf router Ip in DHCP, then reset the phone hopefully it will be registered, if not then add it manually in CCM - it will be registered.

Actions

This Discussion