Cisco Works LMS 2.6 - Device discovery, transient terminated

Answered Question
Sep 3rd, 2007

Hi all,


I was wandering if anyone could help me with my small problem that has just arisen.


I'm running Cisco Works LMS 2.6 and have been for some time with no issues at all. My issue is this, and it started out of the blue. What happens is when I start a device discovery, it comes up with a message saying, "Make sure the seed devices and SNMP community strings are specified, do you want to continue?"


All of these strings are in place as I have made no changes.


When I look in processes, the one for Device Discovery says, transient terminated. I can start it again, but it very quickly changes back again.


Has anyone else had this problem or does anyone have any ideas here?


Kind regards


James M

Correct Answer by Joe Clarke about 9 years 5 months ago

Your DeviceDiscovery.properties is corrupt. This used to occur under earlier versions of LMS 2.5, and has since been fixed. To correct the corruption, you need to copy C:\PROGRA~1\CSCOpx\campus\etc\cwsi\DeviceDiscovery.properties.orig to C:\PROGRA~1\CSCOpx\campus\etc\cwsi\DeviceDiscovery.properties, then modify the DeviceDiscovery.properties and make sure DEVICESROOT is set to:


C:\\PROGRA~1\\CSCOpx\\campus\\lib\\classpath


(The double slashes are critical.)


Then go back to the GUI, and re-enter all of your other settings.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Joe Clarke Mon, 09/03/2007 - 08:16

Please post your discovery.log and NMSROOT/campus/etc/cwsi/DeviceDiscovery.properties.

Correct Answer
Joe Clarke Mon, 09/03/2007 - 09:39

Your DeviceDiscovery.properties is corrupt. This used to occur under earlier versions of LMS 2.5, and has since been fixed. To correct the corruption, you need to copy C:\PROGRA~1\CSCOpx\campus\etc\cwsi\DeviceDiscovery.properties.orig to C:\PROGRA~1\CSCOpx\campus\etc\cwsi\DeviceDiscovery.properties, then modify the DeviceDiscovery.properties and make sure DEVICESROOT is set to:


C:\\PROGRA~1\\CSCOpx\\campus\\lib\\classpath


(The double slashes are critical.)


Then go back to the GUI, and re-enter all of your other settings.

james.mathieson Tue, 09/04/2007 - 00:57

I have tried what you suggested and it is working again.


Many thanks for your help, it was highly appreciated.


Regards.


James M

Actions

This Discussion