Car config example ??????

Unanswered Question
Sep 5th, 2007


I want to ask about CAR that i want to implement this on 10g interface .. of my router ..

I have to allow 155mb for customer kinldy help me out how can i do this .. any doc for help .

Thanks and regard.

Afzaal Qadir

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (3 ratings)
mohammedmahmoud Wed, 09/05/2007 - 04:46

Hi Afzaal,

Please follow these documents, it is that simple:

[edit] You can match your client IPs using ACL and the access-group option.


Mohammed Mahmoud.

afzaalq007 Wed, 09/12/2007 - 22:23

hi Mohammad,

Thanks for ur ans .. i am still confused let me explan the whole scanrio to ..

I have 10 g interface on my router so i have to allow multiple user to to same interface e.g g10/0/0 is my router interface...

i have too allow 4 carrier on this interface with differnt bandwith requirment. so plz confirm the following step mention below according to the my information...

step-1 i will devide my g interface into sub interfaces g.1 , g.2, g.3,g.4 ,,

step-2 than i will define different CAR polies for my 4 customers,

Step-3 than i will implement CAR on sub interfaces .. e.g

customer 1 on g.1

customer 2 on g.2

customer 3 on g.3

customer 4 on g.4

kidlly let me know i am doing the right thing and right steps.

waiting for your Guideline.

Thanks and regard.

Afzaal Qadir

ohassairi Wed, 09/12/2007 - 23:45

it is more simple than that:

suppose your customer IP range is> and you want to give him 2Mbps

interface g10/0/0

ip address

rate-limit input access-group 1 2000000 30000 30000 conform-action transmit exceed-action drop

rate-limit output access-group 1 2000000 30000 30000 conform-action transmit exceed-action drop


access-list 1 permit

foxbatreco Wed, 09/12/2007 - 23:57


Ya u hav to logically divide the gig interface into subinterfaces and say assign each end node(isp)to these.Like::

int gig 0/1

no ip address

duplex full

speed 100

int gig 0/1.101

description isp1

encapsulation dot1q 101

ip address

rate-limit input 2048000 256000 128000 conform-action transmit exceed-action drop .

int gig 0/1.102

des isp2

ip address

rate-limit input 4096000 128000 64000 conform-action transmit exceed-action drop.


Similar lines u can config the other guys.

But i have a suggestion on this.As u basically want to allocate each of ur isp a specific max-bandwidth they can pull, so it would be better if u use MQC with policing applied for better throughput and interface congestion control to avoid drops as with CAR rate limit , lot of drops do occur once the other end is trying to reach the threshold.

But neverthless u can go ahead with ur plan.

Hope this helps u .

Please do rate the post as it would help us to give valuable output useful to all.


afzaalq007 Thu, 09/13/2007 - 03:55


Thanks My friend for such a nice answers

Thanks once agian..

In last Ans we always use Encapsu dot1q (VLAN) it it necessary or ????

and Can u tell me about the MQC how can we doo this..???

thanks and regard

Afzaal Qadir

foxbatreco Thu, 09/13/2007 - 22:02


thnks for accepting the answer.

yes the encapsulation has to be used on every subinterface u create for a particular isp(in ur case) , as u r using logically created interfaces for the traffic flow.This would mean the flow frm each isp wud be having a dotiq tag with it to differentiate it frm other isp flow.The tag wud identify flow and de-tag once it passes of thru the trunk to one of the other core devices..say for eg.backbone/gateway router interface.

AS for MQC ..

int gig 0/1

no ip address

speed , duplex settings..

int gig /1.101

encapsulation dot1q

ip address

service-policy input test1

service-policy input test2

define the policy maps.

class-map movingout

match access-group 150

class-map movingin

match access-group 151

Policy-map test1

class movingin

police 2048000 128000 conform-action transmit

Policy-map test2

class movingout

police 1024000 64000 conform-action transmit exceed-action drop

these are modular class maps attached to policy maps,which define the flow to be considered and then given to policy maps for action .

attaching this to the reqd interface would enforce these rulesets.

Hope this clears ur doubts and helps.

Do let me know if anything more on this is needed.

Please do rate post as before.

policy-map test1


This Discussion