Unity install issues

Unanswered Question
Sep 5th, 2007
User Badges:

When I try to "Set the Sa Password for MSDE", page 56 of the Unity 4.0(4) install gude, I get this error message.

"Microsoft Management Console

Snap-in failed to initialize.

Name :<unknown>

CLSID:{00100100-1816-11D0-*EF5-00AA0062C58F}"

I am installing 4.0(4) on windows 2003 server enterprise edition. Any suggestions?



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Ginger Dillon Wed, 09/05/2007 - 07:33
User Badges:
  • Blue, 1500 points or more

Hi -

Caveat - you may want to check with TAC on this, but I did find this information regarding problems with the SQL Enterprise Manager MMC console not initializing, which is what you are attempting to use to set the SA password:

1. Search the registry for the classid provided in the error you are getting. You will find a key

HKEY_CLASSES_ROOT\CLSID\ (guid related shown in the error message)

2. Under the key click on InProcServer32, you will find the dll, associated

with the GUID.

3. -Unregister the dll, regsvr32 /u dll name


4. -Replace it with the original dll from the CD (I would use Unity CD)


5. -Register the dll, regsvr32 dll name.

Here is the link I referenced if you want to discuss further with TAC - http://www.dbforums.com/showthread.php?threadid=820226

Sincerely, Ginger

kmulkey Wed, 09/05/2007 - 08:01
User Badges:

Thanks, Ginger. I tried it and rebooted but still no luck.

Ginger Dillon Wed, 09/05/2007 - 10:07
User Badges:
  • Blue, 1500 points or more

Hi -

Dang! Sorry that did not work for you!! Since this is happening during the install, I would contact TAC. Reregistering a DLL is usually a safe thing to do (recommend), but having already tried this and not being successful, I would bring in the experts, especially one more versed in SQL than myself.

Ginger

kmulkey Wed, 09/05/2007 - 14:33
User Badges:

OK, I've gotten past that issue with a reinstall. Now I have another. When I try to open up the tree in SQL enterprise manager, it won't see anything past (LOCAL) (Windows NT). Have you ever seen this? Also, the SQL systray icon is not there and the service is not running.

Ginger Dillon Wed, 09/05/2007 - 15:03
User Badges:
  • Blue, 1500 points or more

Hi -

So you are not seeing a + sign next to (local) (Windows NT)? Can you right-click it and select Properties? On the General tab, you should see the Autostart policies when the OS starts checked for all (autostart SQL server, the agent, and MSDTC). Did you reboot after the install?

Ginger

kmulkey Wed, 09/05/2007 - 15:45
User Badges:

Yes, there's a + and when I click it, below it says (Connection failed check sql server registration properties). If I right click on it and choose properties, it gives me a message that says "The sql server \\LOCAL is not known to be running. Are you sure you wish to connect?" I click yes, it pauses for a minute and then comes back with "A connection could not be established to LOCAL. Reason: SQL server does not exist or access denied."

John Clark Wed, 09/05/2007 - 21:37
User Badges:

have you set MSDE to log in as one of your unity accounts?

kmulkey Thu, 09/06/2007 - 04:29
User Badges:

No, not that I remember. I am following the Unity install guide and I don't recall seeing that as one of the steps.

ranpierce Thu, 09/06/2007 - 05:58
User Badges:
  • Silver, 250 points or more

You need to delete the local SQL Server Registration and create a new registration with the servername. It will be the defalt when you go to create one. Create one by right clicking SQL server group after deleting the local one by right clicking on it..


rlp

Actions

This Discussion