Connecting a switch to a 3560

Answered Question
Sep 5th, 2007

I have the following commands configured on a 3560 switch:

spanning-tree portfast default

spanning-tree portfast bpduguard default

interface GigabitEthernet0/9

switchport access vlan 7

switchport mode access

spanning-tree bpdufilter enable

I want to connect a switch to G0/9 but because of the "stp portfast/bpdu default" commands, the port will err-disable. The way round this was to disable STP on the port by configuring the "bpdufilter enable" command on the port, as shown above. This is fine under normal cirumstances but should a loop occur on the other switch then the port will no longer be protected. I know the alternative is not to use the "stp portfast default" command, and instead, configure portfast explicity, except for port G0/9, which will then have stp enabled. Is there another alternative method of configuring the port whilst still being able to use the "stp portfast default" command?

I have this problem too.
0 votes
Correct Answer by avmabe about 9 years 1 month ago

Sure you can. Just go into the specific interface in config mode and enter

(config-if)#spanning-tree portfast disable

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
avmabe Wed, 09/05/2007 - 07:15

Why disable STP on the port?

I would recommend on the port having portfast disabled and bpdufilter disabled.

That is of course, depending on the L2 network design. Who is default root for the vlan 7? Is this other switch a cisco switch? BPDUGuard will turn off the port if a single BPDU is recieved. BPDUfilter will completely ignore BPDUs (even his own if a loop occurs).

russ Thu, 09/06/2007 - 00:43

The 3560 is the root for vlan 7. I found it was not possible to disable portfast on the port when you have the global command "spanning-tree portfast default" configured.

Correct Answer
avmabe Thu, 09/06/2007 - 05:35

Sure you can. Just go into the specific interface in config mode and enter

(config-if)#spanning-tree portfast disable

russ Thu, 09/06/2007 - 08:05

Cheers! not sure why I didn't spot that command.


This Discussion