EIGRP routing problem

Unanswered Question
Sep 5th, 2007

We have a Cisco 1841 that currently connects to a 2821 via a radio link. They decided they wanted to use their old T1 line as a backup link. The T1 connection goes to a Cisco 7609. So I put the T1 card into the 1841 and connected it. I did not connect the wireless link. While I was able to get routing information, the route to the LAN side of the 1841 did not propagate. The route to the LAN was showing up on the cores as going by way of the 2821 (which had no link to the 1841). We had not scheduled sufficient time to troubleshoot such issues, so we disconnected the T1 link, plugged the wireless link back in. When we did that, there was still no route to the LAN side of the 1841. We had to put a static route on the 2821 to get to the LAN off the 1841. I did a sh ip eigrp top active (on the 2821), and that network shows up as Active, waiting on a reply from the next router upstream. The upstream routers have a route to the LAN side, going through the 2821.

Sorry if my explanation isn't so great. But that is the gist of the issue. And the main question: Why do we have to put a static route in now, when we didn't before? What did we mess up?

Thanks for any light you can shed on my problem.

Kari

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
kjackson74 Wed, 09/05/2007 - 15:05

Okay. Please note that, after shutting down the t1 interface, we took the network commands out of the router eigrp config. And I deleted the IPX access list from the config I have posted, but there is one. Also, when we first tried the t1 link, I had not summarized the routes. The 7609 has auto-summary turned on, but the 2821 didn't, so when we plugged both of them in at the same time, all of the t1 traffic was rerouted to go through the 1841, since its routes had the longer prefix. That was not good. I am telling you this just as some background on how our eigrp routing got so messed up. Further, the connection to the 2821 is through a 10. address, so of course the 2821 has no 172 network statement in its config.

Maybe that is more information than you need :)

Thanks!

Attachment: 
Edison Ortiz Wed, 09/05/2007 - 18:31

You need to enable EIGRP on interface Serial0/1/0

Currently, you have 2 interfaces with EIGRP enabled, according to the eigrp config

router eigrp 100

network 10.0.0.0

network 172.17.18.0 0.0.0.255

no auto-summary

1) interface FastEthernet0/0

description Radio Link

ip address 10.100.6.2 255.255.255.0

2) interface FastEthernet0/1

description LAN Side

ip address 172.17.18.1 255.255.255.0

You are missing

3) interface Serial0/1/0

description T1 Connection to 7609

ip address 172.17.0.218 255.255.255.248

Therefore, your eigrp config should look as follow:

router eigrp 100

network 10.0.0.0

network 172.17.18.0 0.0.0.255

network 172.17.0.218 0.0.0.0

no auto-summary

You need to make sure and enable EIGRP on the 7609 side as well. Feel free to post its config.

HTH,

kjackson74 Thu, 09/06/2007 - 03:33

Edison,

Thanks, but when the T1 connection was not shutdown, I did have the network command for the T1 connection. I only took it out after we decided to shutdown the T1 connection and put it back to just the wireless connection.

Pavel Bykov Thu, 09/06/2007 - 09:08

If the route is ACTIVE, for a long time, that is a SIA state. That means that somewhere there is a bad EIGRP connection. In cases like that you can reset the bad EIGRP session (it is reset automatically, but after a long time). And you need to troubleshoot that bad session, why it went into ACTIVE.

You can do this by tracking where routes are in ACTIVE and where there are not active anymore. E.g. if 1841 says that route to some network is active, and 2821 says that it's not active (no route, or some route), then the problem is between 1841 and 2821.

How is the radio link connected? Do you have some wireless devices in between, like MIRACLE solution, or something like that connecting to an fastethernet port? Try increasing delay on your fastethernet to the value that would reflect the real connection speed of the radio link like "delay 500" interface command on both sides.

kjackson74 Thu, 09/06/2007 - 12:38

How do you reset the EIGRP session?

fyi, the devices are connected like:

1841(a)--wireless--2821--wireless--1841(b)--fiber--core.

I did look at the two routers. I did a sh ip eigrp top active. The 2821 has a route in the ACTIVE state, the 1841(b) does not. So I know that the problem is between them, but I don't understand what the problem is. What caused it to get stuck? It sees the 1841(b) as a neighbor, it has learned other routes from the 1841(b). The 1841(b) has to go through the 2821 to get to the route that is SIA (and so we added a static route to the 2821 so that, as it receives traffic destined for that network, it knows where to send it). The 2821 did loose its connection with 1841(a), but when it came back up, I would think that it would receive a hello and routing information that would include the route that is SIA waiting on a reply from 1841(b) and put that in its routing table, but that isn't what happened.

There are radios connected to the routers through the ports, yes. We don't have access to those, they are taken care of by our ISP.

Actions

This Discussion