Push2Phone - Send Text to Phone

Unanswered Question
Sep 5th, 2007

I have created a push2phone program in asp.net that allows for sending text messages to phones, and I was unable to find a free one online so I created my own. I have it working on call manager 4.1(3). It might work with other versions as long as they use the devicelistx.asp file. Here is a link to the program. I also have included screenshots in the download so you can see what the gui looks like before installing.

http://rapidshare.com/files/53657785/IpPhoneMessenger.zip.html

Any suggestions? Comments?

Thanks

Kurt

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Volodymyr Morskyy Fri, 09/07/2007 - 04:52

Thanks for a nice application.Just have one question: which phone models are currently supported? (i'm interested in 7911 and 7912)

kurtmarvin Thu, 11/08/2007 - 08:50

Sorry about the really late response.

I have only tested this on 7941 and 7940's.

Kurt

yannick.methot@... Thu, 09/20/2007 - 11:41

Hi Kurt,

I tried to install your app.. But i get this error message... do you know what is?

Server Error in '/IpPhoneMessenger' Application.

--------------------------------------------------------------------------------

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Unrecognized configuration section 'connectionStrings'

Source Error:

Line 10:

Line 11:

Line 12:

Line 13:

Line 14:

Source File: C:\Inetpub\wwwroot\IpPhoneMessenger\web.config Line: 12

--------------------------------------------------------------------------------

Version Information: Microsoft .NET Framework Version:1.1.4322.573; ASP.NET Version:1.1.4322.573

scott.weismann@... Tue, 09/25/2007 - 13:57

Actually, I figured it out. In IIS, you have to use ASP.NET version 2.0. Once I change that, it's working perfectly.

dradovan Fri, 09/21/2007 - 06:41

Kurt,

is there a way to make this work from an ip phone? A user presses a services url button and that pushes a pre-set message to a group of phones.

Thanks,

Dragi

msabir Wed, 10/03/2007 - 10:48

PhoneTop Messenger does exactly what you are looking for. It allows users to push out pre-typed text messages or live audio pages from an IP phone to other IP phone groups. If you want to type the text message yourself, you can use web interface as well. PhoneTop has gotten many awards from Cisco IP Telephoney User Group (CIPTUG), including "Best in Class".

kurtmarvin Thu, 11/08/2007 - 08:52

Sorry about the extremely late response.

Yeah...This sounds pretty cool i'll see if i can try to add this into the app.

Thanks,

Kurt

seanbelize Tue, 10/09/2007 - 05:58

Followed all the instructions and cant get it to work. When I run the app I receive a message saying:

The website declined to show this webpage

HTTP 403

Most likely causes:

This website requires you to log in.

msabir Tue, 10/09/2007 - 06:00

Try PhoneTop Messenger. It is really easy to install and set up and you get very good support even before you purchase it.

baileja Wed, 10/10/2007 - 09:40

For anybody having problems getting this working, just do the following:

Delete the following line from web.config file:

Make sure your IIS virtual site is running ASP 2.0 (in my computer management, go under Internet Information Services,Web Sites, right click your virtual site and click properties, click the ASP.net tab, and choose 2.0.

Ensure the files in this site are all running from the root directory of your web site. The main files access other files such as the MasterPage.master file and it assumes it is starting from the root, so do not use the folder IpPhoneMessenger, but instead copy the contents of that directory into the root IIS folder.

During your testing, open the page on a browser from the server locally so you get more detailed errors within your testing web browser.

Other than those, the application is very cool and the code looks pretty good too. I cleaned ours up a bit and made it work with the above errors, but it was minimal effort required. Gratz on a job well done!

frankbil Thu, 10/18/2007 - 08:55

Thanks everyone for the help. I can see the website, configure messages to be sent, however, the messages do not appear on the targeted phone. Anyone experience this too?

baileja Thu, 10/18/2007 - 09:00

You probably need to ensure the account specified in the config file has access to the phone. In CCM ensure the user account is created and associate all phones with that user account.

frankbil Thu, 10/18/2007 - 09:18

Checked that already. Is there anything else, perhaps on the CCM that needs to be setup/configured? Are there any illegal characters not allowed in the device description?

Zeek Ferraros Mon, 10/29/2007 - 11:30

I do have the same problem.

I configured everything.

I can see the page with all phones.

When sending the message to a phone, everything looks correct, but the message does not shows on the target phone.

All phones are associated with the user.

Rinnug Call Manager 4.1.3

Any ideas?

Zeek Ferraros Mon, 10/29/2007 - 11:42

I've just narrowed it down a bit.

When sending the message with an alert tone, i DO get the alert tone on the target phone but NO the message.

Thanks,

Please let me know if i need to configure something else.

Thank you,

Zeek

kurtmarvin Thu, 11/08/2007 - 09:40

It seems like you have a firewall blocking incoming connections to the computer where ipPhoneMessenger is on, or you have the wrong url entered in the settings.xml file.

Make sure the "http://wherethissiteishosted/PhoneMessenger/" is the write url.

Also you can't have the ipPhoneMessenger password protected, because the phone has to make a request back to the ipPhoneMessenger.

Well...you might be able to set special permission for the ipPhoneMessenger, except for the Messages folder, because that is where the phone actually makes a request to. I have not tested it with any special permissions though.

Kurt

kurtmarvin Thu, 11/08/2007 - 08:54

Sorry about the late response.

Is there anyway you could send me the changes you made so i can implement them and update the whole app.

Thanks,

Kurt

Zeek Ferraros Mon, 10/29/2007 - 13:38

Still can't figured why it will play the sound on the target phone but won't display the message.

What concerns me is that I've just installed "Message Pusher Demo", and this software it's working correcly.

PLease help, this is driving me crazy!!

Thanks

Zeek

Zeek Ferraros Tue, 10/30/2007 - 07:44

Thank you for replying.

The App Load ID P00308000400

The Boot Load ID PC0303010100

Version 8.0(4.0)

frankbil Tue, 10/30/2007 - 08:02

A few examples from phones that do not work:

App Load ID: Jar70sccp.8-3-0-50.sbn

Boot Load ID: 7970_64060118.bin

Version: SCCP70.8-3-1S

and

App Load ID: Jar41sccp.8-3-0-50.sbn

Boot Load ID: boot41.3-2-2-0.bin

Version: SCCP41.8-3-1S

john.firman Thu, 11/08/2007 - 08:29

I got this installed and am at the point where I can send sounds through but the text does not show up just like previous posts. I am trying this on a 7940 with App Loader P00308000700 and boot loader PC0303010200

kurtmarvin Thu, 11/08/2007 - 08:49

And Sorry to everyone for forgetting about this post that I made. I just have been quite busy lately, and for some reason I wasn't recieving any emails from replys which for some reason I got one today.

What do you get as an error on the phone when you try to send a message?

I had a similar problem like this but the problem for me was that when you send a send a message to the phone it sends xml content to the phone which includes the sound but not the actual message. What the phone does to display the message, it goes out and tries to access the xml page that is stored in the Messages folder.

It seems like for some reason the phone can't make a connection to where your ipPhoneMessenger is. Do you have a firewall that could be blocking it?

And i have only tested this on the Cisco Ip Phone 7941 and 7940 and also a cisco wireless phone which I will have to get the model number of because I can't remember it at the moment, but it seems like it should work with ur app and boot loader.

Kurt

john.firman Thu, 11/08/2007 - 10:57

It was a http 404 page not found error. I moved everything to the root of C and all is working fine now to both 7940's and 7960's.

Thanks for the app! My office admin loves it.

cairns-a Wed, 11/14/2007 - 06:41

We can get the Alert Tone to play on phone and can get a message to save in the messages folder. The phone does not display the message, only get a 404 error.

Any thoughts?

kurtmarvin Wed, 11/14/2007 - 06:50

"I had a similar problem like this. Here is how it works. When a message is sent to the phone it only sends xml content to the phone which contains only the data for the Alert Tone and a link to where another xml file where the message is stored. If for somereason the phone can't make a connection to the xml file that contains the message it will result in a 404 error.

Here are the most comon ways to resolve the problem:

1. Do you have a firewall that could be blocking the phone from accessing the messages folder?

2. Another reason you could be getting the error is if the Messages folder is password protected. The Messages folder has to be available to everyone.

Hope that helps somewhat.

Kurt

cairns-a Wed, 11/14/2007 - 08:14

Thanks for the reply. First let me say this is a nice application. You did a really great job on it.

I think it might be the messages folder now that I understand more how the application works. I will try to find a place for the messages folder that will allow phones to access.

Thanks again for the help.

Trae

kurtmarvin Wed, 11/14/2007 - 09:23

Thanks,

Let me know if you get it working, and good luck :-)

Kurt

cairns-a Thu, 11/15/2007 - 05:04

We got this working. Not sure how, but I guess we got all the files in the right location.

Thanks

Trae

cairns-a Thu, 11/15/2007 - 11:48

I have tested this on 7940, 7960, 7961 and 7921 which all work.

It does not work on the 7970. It resets the phone.

Jamie Brown Wed, 11/21/2007 - 14:06

Hi Kurt,

Have you had any luck sending messages to 7921 phones? They seem to work differently from other phones.

Cheers

Jamie

kurtmarvin Mon, 11/26/2007 - 06:13

cairns-a posted earlier that he had tested it on the 7921 and said it worked.

cairns-a post:

"I have tested this on 7940, 7960, 7961 and 7921 which all work."

I have not tested the phone myself, but going by what he said it should work.

Kurt

jwillisriptown Fri, 11/23/2007 - 15:49

First off, thanks very much for putting this together!

Secondly, I'm having an issue setting it up. We're currently trying to test this out - I have the page displayed with all the ext's, that works, looks good. I have my own account that is associated only to my phone however I'm not able to push a tone or message to it. Will this work or do we actually need all devices associated first off before anything works?

Any advice would be greatly appreciated.

Thanks,

Jon

kurtmarvin Mon, 11/26/2007 - 06:21

If it isn't a problem to associate all the devices then I would try doing that first.

I can't remember exactly, but I think I ran into a problem similiar to yours when I had just one device associated to it. It seems that it should work with only one phone associated to it though. I can't honestly remember though. If you are still having trouble with this I can test it out here.

Thanks,

Kurt

richou68000 Tue, 06/10/2008 - 01:18

Hello,

I want to try your application, are you here in order to help me?

Thank you in advance

Zeek Ferraros Mon, 06/23/2008 - 09:55

In my case, when sending a message to a specific phone, the remote phone rings once but not message is displayed on the screen.

Any ideas?

Thank you,

zeek

ssridhar12 Fri, 03/19/2010 - 03:34

Hi Kurt

This piece of code is awesome, I am looking for your help on the same code for the latest version of CUCM 7.0(2) as that dont support devicelistx.asp so what is to be changed in this application so that i can use this on cucm 7.02 environment

With Best Regards


Iyer

Mustapha Arakji Wed, 04/11/2012 - 02:23

Hi,

I wanted to know, does this require and IP Phone Service to be created for the IP Phones?

Please if anyone has this application, could you post a link, as the old link seem to be expired.

Regards,

Actions

Login or Register to take actions

This Discussion

Posted September 5, 2007 at 9:03 AM
Stats:
Replies:44 Avg. Rating:
Views:3326 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard