Data VLAN getting allocated Voice VLAN IP Address

Unanswered Question
Sep 5th, 2007
User Badges:

Hi,

Strange problem that just came up for one of our old site. Below is the switch configuration on fas0/9. Data VLAN is 997 and voice VLAN is 900 (CallManager)


interface FastEthernet0/9

switchport access vlan 997

switchport mode access

switchport voice vlan 900

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

priority-queue out

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

storm-control broadcast level 20.00

spanning-tree portfast


On our router gateway here is the config for the DHCP


ip dhcp pool 997

network 192.168.5.0 255.255.255.0

dns-server x.x.x.x x.x.x.x

default-router 192.168.5.1

lease 7


interface FastEthernet0/1.997

description SERVCORP VIRTUAL NETWORK

encapsulation dot1Q 997

ip address 192.168.5.1 255.255.255.0

ip accounting output-packets

ip nat inside

ip virtual-reassembly

no ip mroute-cache

no snmp trap link-status

arp timeout 0


For some strange reason, when I manually allocate switchport access vlan 997 to a fas interface, the PC attached to this switch port gets assign the VLAN 900 IP address from CallManager (usually assign to IP Phones).


When I remove the switchport voice vlan 900 from the interface config, and allocate VLAN 997, it get the correct IP address allocated to the PC (192.168.5.x)

Put the switchport voice vlan 900 with the switchport access vlan 997 on the same switch interface, the problem occurs again.


Switch IOS version is "C3560 Software (C3560-IPBASE-M), Version 12.2(25)SEB4"


Any advise?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lgijssel Wed, 09/05/2007 - 23:32
User Badges:
  • Red, 2250 points or more

This kind of behaviour is typical for a native vlan mismatch. This may cause traffic from one vlan to "cross over " to another when it traverses a trunk.

Please check your network for settings that involve the native vlan and the tagging/untagging of frames.


regards,

Leo

Actions

This Discussion