Vlan based EoMPLS

Unanswered Question
Sep 5th, 2007

hi

i know there are several posts on EoMPLS that are similar to mine but for the sake of my understanding bear with me for posting almost a similar post,i am a newbie to the mpls world.

i want to simulate EoMPLS using dynamips,i my scenario i have a HQ with a 7206,the Hq has many other wide spread branches that it must talk to.

i am a bit familiar with layer 3 MPLS VPN using either ospf PE-CE or any other routing protocol.

but now i need someone to give me a lead on the EoMPLS configuration.I have read a few documents from cisco but they are not clear enough.

Can someone help me with the config that maps to my lab scenario.It does not have to be a full config,just the PEs and the CEs.

Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (6 ratings)
Loading.
mheusing Thu, 09/06/2007 - 01:06

Hi,

Your CE config just needs VLAN subinterfaces, switches need a trunk to the PEs allowing the VLAN to be transported.

PE configs:

ip cef

!

hostname R1

!

interface Loopback0

ip address 192.168.1.1 255.255.255.255

!

interface FastEthernet0/0

no ip address

duplex full

!

interface FastEthernet0/0.100

description * VLANoMPLS to R2 F0/0.100 VLAN 100 *

encapsulation dot1Q 100

xconnect 192.168.1.2 666 encapsulation mpls

!

interface FastEthernet0/0.200

encapsulation dot1Q 200

ip address 10.0.12.1 255.255.255.252

!

!

interface POS3/0

description * Link to R2 POS3/0 *

ip address 10.30.12.1 255.255.255.252

mpls label protocol ldp

mpls ip

mpls mtu 1530

!

router ospf 10

router-id 1.1.1.1

log-adjacency-changes

network 10.0.0.0 0.255.255.255 area 0

network 192.168.0.0 0.0.255.255 area 0

!

ip cef

!

hostname R2

!

interface Loopback0

ip address 192.168.1.2 255.255.255.255

!

interface FastEthernet0/0

no ip address

duplex full

!

interface FastEthernet0/0.100

description * VLANoMPLS to R1 F0/0.100 VLAN 100 *

encapsulation dot1Q 100

xconnect 192.168.1.1 666 encapsulation mpls

!

!

interface POS3/0

description * Link to R1 POS3/0 *

ip address 10.30.12.2 255.255.255.252

mpls label protocol ldp

mpls ip

mpls mtu 1530

!

router ospf 10

router-id 2.2.2.2

log-adjacency-changes

network 10.30.12.2 0.0.0.0 area 0

network 192.168.1.2 0.0.0.0 area 0

!

The IOS version used was 12.4 and your CE or switch would connect to F0/0. In case you have further questions do not hesitate to ask.

Hope this helps! Please rate all posts.

Regards, Martin

mheusing Thu, 09/06/2007 - 06:40

Hi,

POS is Packet Over Sonet. It is a technology to transport packets (f.e. with HDLC or PPP) over a SONET/SDH infrastructure.

Dynamips supports POS interfaces. replace the POS with ethernet or anything else connecting the PEs.

Regards, Martin

san-pandey Thu, 09/06/2007 - 07:20

Hi Martin,

Can EoMPLS so point to multipoint? Just like frame relay (hub and spoke) can there me more than 1 VC to a site. I am not sure if multiple sub-interface can be created (PE and CE) to provide a point to multipoint netwokr topology.

Thanks,

San

swaroop.potdar Thu, 09/06/2007 - 08:43

San,

As Jay pointed out you will have to use VPLS for point to multipoint applicable for ethernet only.

But you will not be able to test this with dynamips due to support not being there in 72xx.

Although you can try to run multiple P2P VC's to create a full mesh between the CE's and simulate the same for academic purpose.

HTH-Cheers,

Swaroop

mheusing Fri, 09/07/2007 - 03:09

Hi San,

EoMPLS supports multiple VCs per physical interface. Do you spot the VC ID "666" in my sample config? Make sure it is the same at both ends for a single VC and different for different VCs on a single box. So you can create additional subinterfaces for additional VLANs and transport each VLAN to a different destination (or the same).

One note: the concept of "point-to-multipoint" like in frame relay is not possible with EoMPLS, as you need a subinterface per VLAN. This would be "point-to-point" in Frame relay, if this analogy sounds helpful to you.

VPLS is a quite different thing and much more complex. In few words:

EoMPLS = "cat5 cable simulator" therefore also called "Pseudowire"

VPLS = "LAN Switch simulator", which means MAC address learning, flooding of broadcast and unknown, all sorts of loop issues, etc.

Hope this helps! Please rate all posts.

Regards, Martin

san-pandey Fri, 09/07/2007 - 04:27

Hi Martin,

Thanks. got it!! create additional subinterface on the same port and create another vcid 777; on the far end link another site with the same vcid 777.

My mistake i meant to say point-to-point in Frame relay through multiple pvc connecting back to the same Hub site, making it a hub and spoke (point to multipoint in a way).

thanks,

san

Actions

This Discussion