native VLAN

Answered Question
Sep 6th, 2007

Hi,

i have a cisco 2950 switch. onfiguration on interface is:

interface FastEthernet0/22

switchport trunk native vlan 101

switchport mode access

spanning-tree portfast

My question: when i connect a new pc for example to this port, in which VLAN will this pc belong 1 or 101? And why?

Thaks.

Lubo

I have this problem too.
0 votes
Correct Answer by mohammedmahmoud about 9 years 3 months ago

Hi Lubo,

It will be VLAN 1, since you have configured the switchport as a static access port, and then any trunking commands is irrelevant.

Rack1SW1(config)#interface f0/23

Rack1SW1(config-if)#switchport trunk native vlan 101

Rack1SW1(config-if)#switchport mode access

Rack1SW1(config-if)#

Rack1SW1(config-if)#

Rack1SW1(config-if)#^Z

Rack1SW1#sh int

Rack1SW1#sh interfaces

19:12:02: %SYS-5-CONFIG_I: Configured from console by console

Rack1SW1#sh interfaces f0/23 sw

Rack1SW1#sh interfaces f0/23 switchport

Name: Fa0/23

Switchport: Enabled

Administrative Mode: static access

Operational Mode: down

Administrative Trunking Encapsulation: negotiate

Negotiation of Trunking: Off

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 101 (Inactive)

Administrative Native VLAN tagging: enabled

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk Native VLAN tagging: enabled

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Protected: false

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

Appliance trust: none

Rack1SW1#

HTH,

Mohammed Mahmoud.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Correct Answer
mohammedmahmoud Thu, 09/06/2007 - 06:01

Hi Lubo,

It will be VLAN 1, since you have configured the switchport as a static access port, and then any trunking commands is irrelevant.

Rack1SW1(config)#interface f0/23

Rack1SW1(config-if)#switchport trunk native vlan 101

Rack1SW1(config-if)#switchport mode access

Rack1SW1(config-if)#

Rack1SW1(config-if)#

Rack1SW1(config-if)#^Z

Rack1SW1#sh int

Rack1SW1#sh interfaces

19:12:02: %SYS-5-CONFIG_I: Configured from console by console

Rack1SW1#sh interfaces f0/23 sw

Rack1SW1#sh interfaces f0/23 switchport

Name: Fa0/23

Switchport: Enabled

Administrative Mode: static access

Operational Mode: down

Administrative Trunking Encapsulation: negotiate

Negotiation of Trunking: Off

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 101 (Inactive)

Administrative Native VLAN tagging: enabled

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk Native VLAN tagging: enabled

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Protected: false

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

Appliance trust: none

Rack1SW1#

HTH,

Mohammed Mahmoud.

Actions

This Discussion