Netflow on catos

Unanswered Question
Sep 6th, 2007

Hi everybody,

i'd like to know if we can use netflow with a 5000 series router.

we've tried the following config on a

WS-C5000 Software, Version McpSW: 5.5(13a) NmpSW: 5.5(13a)

here's our config :

set mls flow full

set mls nde enable

set mls nde 9996

netflow can't detect the switch.

When we launch a show command, we get the following output:

Total packets switched = 0

Total Active MLS entries = 0

IP Multilayer switching enabled

IP Multilayer switching aging time = 256 seconds

IP Multilayer switching fast aging time = 0 seconds, packet threshold = 0

IP Current flow mask is Full flow

Configured flow mask is Full flow

Active IP MLS entries = 0

Netflow Data Export enabled

Netflow Data Export configured for port 9996 on host

Total packets exported = 0

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Jan Nejman Fri, 09/07/2007 - 05:35


your configuration seems OK. Did you configure a default gateway? Can you reach (try a ping) your collector? I think that you need to configure 'set mls rp', because netflow collects L3 information, and this is not available on a standalone switch. Do you using Cisco router for routing data flows? I'm not sure if 'mls rp' is good tip, I've never configured it... But I'm personally interested in your problem. Can you mail me results to my email or to the forum?

Kind regards,


harinirina Mon, 09/10/2007 - 22:38

Hi everybody,

Thanks all for the reply.

There's a default gateway and we can ping the collector.

i tried to configure 'set mls rp' but the option RP is not listed under 'set mls'.

is it a hardware or software issue.

Our catos is WS-C5000 Software, Version McpSW: 5.5(13a) NmpSW: 5.5(13a).

The following modules are installed on the switch :

-100BaseFX MMF Supervisor WS-X5530


-uplink WS-U5533

-10/100BaseTX Ethernet WS-X5225R and WS-X5234


This Discussion