CME BACD script wont route to hunt groups

Unanswered Question
Sep 6th, 2007
User Badges:

I just activeated the CME BACD TCL script. It is answering calls, playing prompts and allowing users to use the dial_by_extension feature however I can not get the script to route to a hunt group.


I have two hunt groups setup. When a caller selects an option from the main menu that is associated with a hunt group they hear MOH for about 10 seconds and then the system plays a message that says "sorry we are unable to complete your call" (or something like that).


The hunt groups work if you dial them manually. Do the users need to do anything else to make their phones available? DND is not on.


Here is the config: (this is a CME version 124-11XJ ? integrated with Unity 5.0)


application

service aa flash:app-b-acd-aa-2.1.2.2.tcl

paramspace english index 1

param handoff-string aa

param dial-by-extension-option 1

paramspace english language en

param max-time-vm-retry 1

param aa-pilot 6099

param max-extension-length 4

paramspace english location flash:

param welcome-prompt _bacd_welcome.au

param voice-mail 1000

param max-time-call-retry 250

param service-name queue

!

service queue flash:app-b-acd-2.1.2.2.tcl

param aa-hunt2 1111

param aa-hunt3 2222

param queue-len 10

param aa-pilot 6099

param queue-manager-debugs 1

param number-of-hunt-grps 4

!

service load aa

!


dial-peer voice 1000 voip

description Auto Attendant

service aa

destination-pattern 6099

session target ipv4:10.10.10.10

incoming called-number 6099

dtmf-relay h245-alphanumeric

codec g711ulaw

!

ephone-dn 1

number 6000 secondary 6000

label Test 1

description Test 1

name Test

call-forward busy 1000

call-forward noan 1000 timeout 10

hold-alert 30 originator

!

ephone-dn 2 dual-line

number 6001 secondary 6001

label Test 2

description Test 2

call-forward busy 1000

call-forward noan 1000 timeout 10

no huntstop

hold-alert 30 originator

!

ephone 1

video

mac-address 001D.4561.4C29

type 7941

button 1:1

pin 1234

!

ephone 42

video

mac-address 001D.4561.5852

type 7941

button 1:2

pin 1234

!

ephone-hunt 1 sequential

pilot 1111

list 6000, 6001

timeout 10, 10

display-logout DND / Logged Off

!

ephone-hunt 2 sequential

pilot 2222

list 6001, 6000

timeout 10, 10

display-logout DND / Logged Off


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
craiglcve Fri, 09/07/2007 - 09:32
User Badges:

Here is a working config. You dont need the param aa-pilot 6099 under the service queue. Also do a dir on the router and make sure that you have all the following audio files specifically the en_bacd_music_on_hold.au file



ccme#dir

25 -rw- 75650 Nov 29 2006 16:30:06 -07:00 en_bacd_allagentsbusy.au

26 -rw- 83291 Nov 29 2006 16:30:06 -07:00 en_bacd_disconnect.au

27 -rw- 63055 Nov 29 2006 16:30:06 -07:00 en_bacd_enter_dest.au

28 -rw- 37952 Nov 29 2006 16:30:06 -07:00 en_bacd_invalidoption.au

29 -rw- 496521 Nov 29 2006 16:30:08 -07:00 en_bacd_music_on_hold.au

30 -rw- 123446 Nov 29 2006 16:30:08 -07:00 en_bacd_options_menu.au

31 -rw- 42978 Nov 29 2006 16:30:08 -07:00 en_bacd_welcome.au





Here is my config. I break my dial peers up into two seperate dial peers but it works both ways.


application

service queue flash:app-b-acd-2.1.2.2.tcl

param queue-len 10

param aa-hunt1 2005

param aa-hunt2 2006

param number-of-hunt-grps 2

param queue-manager-debugs 1

!

service aa flash:app-b-acd-aa-2.1.2.2.tcl

paramspace english index 0

param number-of-hunt-grps 2

param handoff-string aa

param dial-by-extension-option 3

paramspace english language en

param max-time-vm-retry 2

param aa-pilot 2004

param second-greeting-time 30

param call-retry-timer 5

param max-time-call-retry 180

param voice-mail 7000

param service-name queue




dial-peer voice 201 voip

service aa

incoming called-number 2004

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 202 voip

destination-pattern 2004

session target ipv4:192.168.0.1

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad



ephone-hunt 1 sequential

pilot 2005

list 2001

timeout 120

!

!

ephone-hunt 2 sequential

pilot 2006

list 2000

joelalli123 Fri, 09/07/2007 - 12:21
User Badges:

I copied your working config but it doesn't work for me. I have the exact same problem. I am starting to think this is a bug. Has anyone successfully got this to work with 124-11XJ? What version are you running?


The only change I made to your configuration was the voice mail number and I added an audio prompt (which works fine). Here is the new config and debug:


application

service aa flash:app-b-acd-aa-2.1.2.2.tcl

paramspace english index 0

param number-of-hunt-grps 2

param handoff-string aa

param dial-by-extension-option 3

paramspace english language en

param max-time-vm-retry 2

param aa-pilot 2004

paramspace english location flash:

param second-greeting-time 30

param welcome-prompt _bacd_welcome.au

param call-retry-timer 5

param voice-mail 1000

param max-time-call-retry 180

param service-name queue

!

service queue flash:app-b-acd-2.1.2.2.tcl

param queue-len 10

param aa-hunt1 2005

param queue-manager-debugs 1

param number-of-hunt-grps 2

param aa-hunt2 2006


dial-peer voice 201 voip

service aa

incoming called-number 2004

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 202 voip

destination-pattern 2004

session target ipv4:10.2.70.1

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad


ephone-hunt 1 sequential

pilot 2005

list 6000

timeout 120



debug voice application script:


Sep 7 13:04:40.562 PST: //179//TCL :/tcl_PutsObjCmd: TCL AA: ++ Playing Welcom

e Prompt and options menu ++

*Sep 7 13:04:40.822 PST: //179//AFW_:/AFW_FSM_Drive: Tcl_Eval to drive FSM insi

de Tcl modulespace. code=1 code=ERROR

*Sep 7 13:04:40.822 PST: TCL script failure

Result:

syntax error in expression " ([info exists msg_array(op

tionIDX)] == 1) && ([info exists "

*Sep 7 13:04:40.822 PST: TCL script failure errorInfo:

syntax error in expression " ([info exists msg_array(opt

ionIDX)] == 1) && ([info exists "

("if" test expression)

while compiling

"if { ([info exists msg_array(optionIDX)] == 1) && ([info exists msg_array(callS

tate)] ==1)\

&& ([info exists msg_array(keepTime)] == 1)} {

if {[..."

(compiling body of proc "QueueManager.Get", line 32)

invoked from within

"QueueManager.Get"


Paolo Bevilacqua Fri, 09/07/2007 - 12:29
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Joe,

you are getting syntax errors in the cisco-provided TCL. This is not normal, are you positive about the integrity of the script ?

(I haven't checked the exact line and why the error)

joelalli123 Fri, 09/07/2007 - 13:17
User Badges:

I have uploaded the scripts 3 different times and they were obtained from 3 different sources. They should be fine.

craiglcve Fri, 09/07/2007 - 13:20
User Badges:

My lab CME's are Version 12.4(4)XC5 and 12.4(4)XC6.

I would try loading another version of BACD on the router. Either BACD 2.1.0.0 or BACD 2.0.1.0

Then rebuild your aplication using the older version of bacd...


service aa flash:app-b-acd-aa-2.1.0.0.tcl

service queue flash:app-b-acd-2.1.0.0.tcl

also did you verify you have the en_bacd_music_on_hold.au in flash? There was a bug related to that audio file missing and calls failing.



Paolo Bevilacqua Fri, 09/07/2007 - 14:04
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

I routinely use 2.1.2.3 to which I even made some mods, works fine. Most definitely you should not ever get syntax errors from scripts.

joelalli123 Thu, 09/13/2007 - 09:53
User Badges:

Its working now. I made the mistake of extracting the BACD files first then moving them to flash instead of using the archive tar /xtract method. Thanks for your help

Actions

This Discussion