Push XML to IP Communicator

Unanswered Question
Sep 7th, 2007

Hi all,

I have a question about the Cisco IP Communicator. Is it possible to push (via http) XML to a IP Communicator?

I've got a application that pushes xml to a specific IP Phone (http://IP_ADRES/CGI/Execute), but i recieve an error when it pushes to a IP Communicator: (405) Method Not Allowed

It sounds logic to me because the IP Communicator is running on my Laptop so I'm pushing the xml to my Laptop and directly to the phone device.

Is it somehow possible to push xml to a IP Communicator?

Thanks in advance!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
msabir Fri, 09/07/2007 - 06:17

Yes, we do it all the time.

The only problem you may run into, is when you have another application on the same laptop, which is using port 80. Then when you push, it can go to that app, instead of phone and you might get an error as the other web server will refuse the connection or give you file not found error.

Mike-1985 Fri, 09/07/2007 - 06:26

Thanks... I've also IIS running on the same machine, i'll shut it down and test again!

edit:

it works :-)

stephane.lhp Tue, 04/22/2008 - 08:08

Hi !

I've the same problem with my CISCO IP COMMUNICATOR.

I shut down IIS Web Server, and now, nothing is listening on the 80 port.

How could I specify to the IP Communicator, to listen on it?

Please, help me, i still have this error message : "Can't reach address ..." or "Error 405" when IIS is running.

stephan.steiner Wed, 04/23/2008 - 00:22

Do you start the IPC before or after shutting down IIS?

If it's before.. that's your problem.. the IPC disables its webserver if something uses port 80.

Also, in ccmadmin, you can configure for each phone whether the built-in webserver should be active or not.. so if it's turned off.. that would also explain why you never see the webserver even when IIS is not running.

stephane.lhp Thu, 04/24/2008 - 01:28

I started IPC after shutting down IIS and after a system reboot.

Now, when I take a look with NETSTAT -an, there is no process listening on the port 80.

My IPC web server is still down.

I didn't found in CCMADMIN the way to configure the built-in webserver. Where can I found this ?

Perhaps it will solve my problem...

Thanks in advance.

stephane.lhp Thu, 04/24/2008 - 03:50

Hi again.

I found the problem.

Actually, it was a REGEDIT KEY which has been modified.

HERE IS HOW TO ACTIVATE THE IP COMMUNICATOR WEB SERVER :

START > EXECUTE > REGEDIT

Go to the following KEY :

HKLM > SOFTWARE > Cisco System, Inc. > Communicator

CREATE A NEW DWORD KEY :

"WebServerDisabled" and PUT "0" in value (0x00000000(0) value).

TO DISABLE AGAIN IP COMMUNICATOR WEB SERVER :

You need to put a NON ZERO value to the "WebServerDisabled" key. (for example, put "1" (0x00000001(1) value).

Please, rate this post if it helps someone to solve such problem. Thanks.

stephan.steiner Thu, 04/24/2008 - 04:18

In CCM6, the parameter is called "Web AccessRequired" and it's in the

Product Specific Configuration Layout

section (at the bottom of the phone config)

Actions

This Discussion