BGP

Unanswered Question
Sep 7th, 2007
User Badges:

Hello,


I have 3 upstream providers. When I make prepend on one of providers, both upload and download change significantly.

I thought that with prepend I only influence incoming traffic (download) and with the local preference outgoing traffic (upload). On MRTG I see that both in & out traffic is getting down on provider that I made prepend, and on the other two both in & out is getting up. Does anyone know what is the explenation for this?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Antonio_1_2 Sun, 09/09/2007 - 23:50
User Badges:

Yes I use route-maps applied only outbound (toward upstream providers).


Config is something like this:


router bgp 6666

neighbor 1.1.1.1 remote-as 7777

neighbor 2.2.2.2 remote-as 8888

neighbor 3.3.3.3 remote-as 9999

address-family ipv4

neighbor 1.1.1.1 route-map FIRST_OUT out

neighbor 2.2.2.2 route-map SECOND_OUT out

neighbor 3.3.3.3 route-map THIRD_OUT out


ip prefix-list PREFIX seq 10 permit x


route-map FIRST_OUT permit 10

match ip address prefix-list PREFIX

set as-path prepend 6666


route-map SECOND_OUT permit 10

match ip address prefix-list PREFIX

set as-path prepend 6666 6666

cjnwodo Mon, 09/10/2007 - 02:28
User Badges:

Hi,


Based on the config you showed. Anyone on beyond your network who wants to route to network x will aim for 1.1.1.1 which will inturn aim for the router that you applied this config [the one you pasted here] on.


Assumption is that you have a seperate physical interface peer EBGP neighbor.


The followinf link may help you:

http://www.cisco.com/warp/public/459/25.shtml

Hi,


As I know in case of prepending the AS number is only added when the routing update sent an even don't see when checking what advertised to the particular neighbor therefore it shouldn't affect the backward traffic (the bgp topology you have), but for sure I always tuned the localpref if wanted to influence the outgoing route selection as well.


Krisztian

cjnwodo Mon, 09/10/2007 - 04:26
User Badges:

Hi,


I may be wrong here but I'm 99% sure that setting local prefernce on an outbound EBGP peering does nothing!


Let me explain: If you do set LP outbound across an EBGP, the prefix that the EBGP peer receives will still have the default LP of 100. LP does not cross an EBGP boundary. The BGP attributes that can be set outbound to an EBGP peer that affects 'download' or incoming traffic are: prepending AS, MED, BGP router id, Origin.


However, you can set LP inbound on the receving router of an EBGP peering.

Actions

This Discussion