ISSUE: EIGRP config for L3 links between 6509 and 4510R

Unanswered Question
Sep 7th, 2007

Hello Guys,

Currently I'm in the process of implementing L3 links for our campus network.

I'm having following issue with EIGRP routing.

1. 6509 core switch (L3)

2. 4510 access switch (L3 uplink /L2 access)

I have created port channels (for bandwidth aggregation) between 6500 and 4500 switch.


Issue is i'm unable to route or see the route updates from eigrp on core switch for the vlan on Access switch.


Following is the configuration from both 4500 switch and 6500 switch.


Please let me know about the missing configuration.


Cisco 4510R (Access switch) configuration

------------------------------------------

vtp domain xxx

vtp mode transparent

!

key chain eigrp

key 100

!


vlan 24-25

!

interface port-channel1

description link to new core1

ip address 10.211.254.42 255.255.255.252

ip authenentication mode eigrp 100 md5

ip authentication key-chain eigrp 100 eigrp

ip pim sparse-mode

logging event link-status

load-interval 30

carrier-delay msec 0

qos trust dscp

!

interface port-channel2

ip address 10.211.254.142 255.255.255.252

ip authenentication mode eigrp 100 md5

ip authentication key-chain eigrp 100 eigrp

ip pim sparse-mode

logging event link-status

load-interval 30

carrier-delay msec 0

qos trust dscp

!

interface gigabitethernet 5/48

switchport access vlan 24

switchport mode access

spanning-tree portfast

!

interface vlan24

ip address 10.211.24.1 255.255.252.0

no ip redirects

ip pim query-interval 250 msec

ip pim sparse-mode

ip summary-address eigrp 100 10.211.24.0 255.255.252.0 5

!

router eigrp 100

passive-interface default

no passive-interface port-channel1

no passive-interface port-channel2

network 10.0.0.0

no auto-summary

eigrp stub connected

!


Switch#sh ip eigrp top

IP-EIGRP Topology Table for AS(100)/ID(10.211.1.25)


Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

r - reply Status, s - sia Status


P 10.211.254.40/30, 1 successors, FD is 1536

via Connected, Port-channel1

P 10.211.254.140/30, 1 successors, FD is 1536

via Connected, Port-channel2

P 10.211.24.0/22, 1 successors, FD is 2816

via Connected, Vlan24

*******************************************************

Cisco 6509 switch (core/distribution) configuration

-------------------------------------------------------


vtp domain xxx

vtp mode transparent

ip subnet-zero

!


interface Port-channel1

description link to

ip address 10.211.254.41 255.255.255.252

ip pim sparse-mode

ip authentication mode eigrp 100 md5

ip authentication key-chain eigrp 100 eigrp

logging event link-status

load-interval 30

carrier-delay msec 0

mls qos trust dscp

!

interface Port-channel2

ip address 10.211.254.141 255.255.255.252

ip pim sparse-mode

ip authentication mode eigrp 100 md5

ip authentication key-chain eigrp 100 eigrp

logging event link-status

load-interval 30

carrier-delay msec 0

mls qos trust dscp

!

router eigrp 100

network 10.0.0.0

distribute-list Default out Port-channel1

distribute-list Default out Port-channel2

no auto-summary

!

ip access-list standard Default

permit 0.0.0.0

permit 10.0.0.0

!


NEW65C1#sh ip eigrp top

IP-EIGRP Topology Table for AS(100)/ID(10.211.254.141)


Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

r - reply Status, s - sia Status


P 10.211.254.40/30, 1 successors, FD is 1536

via Connected, Port-channel1

P 10.211.254.140/30, 1 successors, FD is 1536

via Connected, Port-channel2



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
umedryk Thu, 09/13/2007 - 11:06

These are not synchronized between the active and standby supervisors:

All Layer 3 protocols on Catalyst 4500 Series Switches (Switch Virtual Interfaces)

Cisco NonStop Forwarding (NSF) works with SSO to minimize the amount of time that a Layer 3 network is unavailable after a supervisor engine switchover by continuing to forward IP packets. The reconvergence of Layer 3 routing protocols (Border Gateway Protocol [BGP], Enhanced Interior Gateway Routing Protocol [EIGRP], Open Shortest Path First [OSPF] v2, and Intermediate System-to-Intermediate System [IS-IS]) is transparent to the user and occurs automatically in the background. The routing protocols recover routing information from neighbor devices and rebuild the Cisco Express Forwarding (CEF) table


Actions

This Discussion